[ntp:questions] Maximum time2 fudge value for NMEA refclock?

David Lord snews at lordynet.org
Mon Jul 19 14:34:03 UTC 2010

David J Taylor wrote:
> "David Lord" <snews at lordynet.org> wrote in message 
> news:qmldh7-k2e.ln1 at p4x2400c.home.lordynet.org...
> []
>> When I first tried parallel port PPS I had to google and
>> unusually it didn't take much searching to find a bug report
>> and that the issue was fixed in later versions of ntpd.
>> I think it was [1238] fixed in ntpd-4.2.6
>> The problem shows when the pps comes from another source,
>> eg. gps2 and pps0 and the absence of serial DCD to gps2.
> So the PPS and the "GPS" signals are not on the same port as far as NTP 
> is concerned.  That's what you're say, I think?

Yes for parallel port. There were errors when I tried setting
/dev/pps0 from parallel and /dev/gps0 from serial.

It's also possible that leaving the serial port DCD connected
is useful, or not, as it appeared to remove the problem but
then I wasn't sure if PPS was from parallel port or serial DCD
or both.

When I used one of internet servers as prefer, and no GPS2,
the problem also went away but PPS0 stratum was increased.


More information about the questions mailing list