[ntp:questions] Trimble Resolution SMT

Thomas Laus lausts at acm.org
Thu May 6 13:10:17 UTC 2010

On 2010-05-05, Hal Murray <hal-usenet at ip-64-139-1-69.sjc.megapath.net> wrote:
> In article <4BE025AA.4050804 at signaturealpha.com>,
>  Marc Leclerc <marc-leclerc at signaturealpha.com> writes:
>>I am trying to have NTP use the trimble resolution SMT gps module, I
>>have tried other trimble clock driver without success so I assume that
>>one specific to the module has to be used. Unfortunately there does not
>>seems to be any way to search the mailing list to see if this was
>>discuss before. I would appreciate if anyone with information could get
>>back to me.
>>I am trying to make this work on an embedded linux platform, I already
>>have the linuxpps driver installed and have the /dev/pps0 node
>>available. the module is wired to /dev/ttyS1. Using the clock driver for
>>the palisade lead to wrong answer format messages.
> The Palisade driver supports several different variations of
> Trimble products.  Which one(s) did you try?
> The data sheet says it speaks TISP and NMEA.  I don't know which
> one is the default.  You might try running some helper code 
> before starting ntpd to switch it to NMEA mode, and then telling
> ntpd that it's a NMEA device.
There might be some issues with your serial port connection to the
receiver.  You might want to pipe the serial I/O to your console and
monitor what is being sent and received from the serial port.  I have used a
Trimble Thunderbolt for NTP and it also uses the TSIP protocol.  The
Palasades driver worked for me, but I had issues with getting the
Thunderbolt to serve the time after a NTP poll instead of whenever it
chose.  My receiver came with a RS-232 interface, but a lot of Trimble
OEM products are RS-422 single ended and require a converter to RS-232
standard serial port.

Since your clock is supposed to understand TSIP, there might be a
program from Trimble that lets you talk directly to your clock to make
sure that it is operational, has a valid position and your serial level
converter is working.  If your module does not have a diagnostic
utility, you may try the one for the Thunderbolt.  The Trimble website
has these utilities.


Public Keys:
PGP KeyID = 0x5F22FDC1
GnuPG KeyID = 0x620836CF

More information about the questions mailing list