[ntp:questions] serialPPS+gpsd+ntpd large offset & jitter

Miroslav Lichvar mlichvar at redhat.com
Sun Oct 17 15:52:39 UTC 2010

On Sat, Oct 16, 2010 at 08:24:02AM -0700, M Z wrote:
> I have since run ntp on 2 other similar systems, with and without the gps. It 
> seems that the problem is not with the gps but with ntp as there is always a 
> large offset and jitter. I have tried some things from the ntp.org problems page 
> such as setting HZ=100, setting clocksource to tsc, hpet, and  acpi_pm. I do not 
> know what to do with acpi so i didn't test that. one of my systems has drift of 
> < +-10 which is good. one of the systems is not behind my firewall.
> I have snipped all gps info out below as i only want to know what to do with ntp 
> now.

Any interesting ntpd messages in syslog?

One additional thing you could try is to disable the kernel discline
by adding "disable kernel" to ntp.conf. If this helps, it's a kernel
bug or possibly a nano/micro mismatch between kernel and ntpd.

Miroslav Lichvar

More information about the questions mailing list