[ntp:questions] NTPd looses sync regularly / 12 hour intervals.

Dave Hart hart at ntp.org
Wed Sep 8 15:33:19 UTC 2010


On Wed, Sep 8, 2010 at 06:40 UTC, Michael Nielsen <hael at tv2.dk> wrote:
> I have two ntp servers set up in the local network, from which another
> 40 odd servers synchronise.
>
> Some of the servers do function as expected, and keep time quite
> accurately, however, the
> majority of   servers rapport an error that I cannot lock down, and it's
> currently baffling me...
> (It's probably  something obvious I'm overlooking or so I hope).
>
> The logs on the systems that have problems usually show the following
> pattern
>
> Sep  7 17:43:48 sn ntpd[11721]: synchronized to 10.7.100.28, stratum 2
> Sep  7 17:57:51 sn ntpd[11721]: time reset +71.784598 s
> Sep  7 17:59:10 sn ntpd[11721]: synchronized to 10.7.100.27, stratum 2
> Sep  8 05:29:11 sn ntpd[11721]: no servers reachable
> Sep  8 05:34:37 sn ntpd[11721]: synchronized to 10.7.100.28, stratum 2
> Sep  8 05:35:52 sn ntpd[11721]: time reset +74.977115 s
> Sep  8 05:36:41 sn ntpd[11721]: synchronized to 10.7.100.28, stratum 2

Since the problem happens on most but not all NTP clients, the NTP
servers can probably be assumed to be working correctly.  Are some of
these 40 NTP clients virtual machines?  A repeated pattern of losing
time due to lost interrupts could be caused by the virtualization
environment and the load on the real hardware.

If that doesn't pan out, compare logs from multiple NTP clients
covering the same time period to see if there's a pattern of server
misbehavior to be detected.

Good hunting,
Dave Hart



More information about the questions mailing list