[ntp:questions] NTP 4.2.6p3 multicast server not visible in orphan peer to peer mode?

Steve Kostecke kostecke at ntp.org
Wed Apr 6 15:06:55 UTC 2011


On 2011-04-06, Wu, Bailey <Bailey.Wu at thalesgroup.com.au> wrote:

> My setting for clients and server are very similar to those below. but
> the HPUX clients seem to only see two servers at a time (instead of 4
> as would be expected). I'm also noticing that some solaris clients are
> not able to ntpdate to the servers.

Please hard-break your text at ~65 columns.

> Here's my ntp config files.

There's nothing about NTP auth in any of your config files. So I'm going
to have to assume that you're disabling it on the command line.

I'd set up the servers this way if it does not matter which one is the
master:

# /etc/ntp.conf for server 1 & 2
driftfile /var/ntp/ntp.drift
restrict default nomodify
restrict 127.0.0.1
tos orphan 10
manycastclient 224.0.1.1
manycastserver 224.0.1.1

I'd set up the servers this way to have server one as the master (with
failover to server 2)

# /etc/ntp.conf for server 1
driftfile /var/ntp/ntp.drift
restrict default nomodify
restrict 127.0.0.1
manycastserver 224.0.1.1
server 127.127.0.1
fudge 127.127.0.1 stratum 10

# /etc/ntp.conf for server 2
driftfile /var/ntp/ntp.drift
restrict default nomodify
restrict 127.0.0.1
tos orphan 12
manycastclient 224.0.1.1
manycastserver 224.0.1.1

> I originally had the following restrict options for the servers:
> restrict -4 default kod notrap nomodify noquery
> restrict <interface1> mask <mask1>
> restrict <interface2> mask <mask2>
> restrict 127.0.0.1
> restrict ::1

This is likely overkill for your disconnected network.

Please keep in mind that your configuration has NTP on the server(s)
following the system clock. You need a time source if you want stable
clocks.

-- 
Steve Kostecke <kostecke at ntp.org>
NTP Public Services Project - http://support.ntp.org/




More information about the questions mailing list