[ntp:questions] Sure GPS - Very High Jitter and Offset

Ken Link klink at numberzero.org
Fri Aug 5 02:09:12 UTC 2011


My Sure Electronics GPS finally arrived a few days ago, and I'm having
some trouble getting it stabilized. I'm running Windows 7 x64, with
the latest serialpps.sys driver (20110720), NTP 4.2.6p3 compiled on
the same machine. I also compiled and ran the code from an email chain
back in April to reprogram the module to only send $GPGGA - which it
does. It's set to 115200bps now, although it didn't appear to have any
effect on jitter/offset from 9600, 19200, 38400, and 115200 that I can
tell. I've turned off UART buffers to the COM port. I haven't soldered
a wire to get PPS to the serial port yet, but I plan to once I get it
stabilized.

ntp.conf:
driftfile "C:\Program Files (x86)\NTP\etc\ntp.drift"
server 127.127.1.0
fudge 127.127.1.0 stratum 12
server 127.127.20.1 mode 82 minpoll 4 prefer
server 127.127.22.1 minpoll 4
server 0.us.pool.ntp.org iburst
server 1.us.pool.ntp.org iburst
server 2.us.pool.ntp.org iburst
server 3.us.pool.ntp.org iburst
server ntp.numberzero.org iburst
peer 192.168.1.3 iburst
peer 192.168.1.4 iburst
enable stats
statsdir "C:\Program Files (x86)\NTP\etc\"
statistics loopstats

The problem is the offset for the Sure GPS consistently varies between
-250ms and -350ms, and the jitter roughly between 5ms and 35ms.
Obviously, ntpd rejects it and picks something from the pool instead.
Any ideas why it could be so unstable/inaccurate? I must be forgetting
something obvious. Here is my ntpq -p: http://i.imgur.com/gNURx.png

Thanks in advance!



More information about the questions mailing list