[ntp:questions] help - local ntp server not serving

hymie! hymie at lactose.homelinux.net
Thu Mar 3 14:59:43 UTC 2011


Greetings.

I'm almost positive this used to work, but I can't NTP to work inside
my network.

/etc/ntp.conf on my local NTP server:
server 0.us.pool.ntp.org
server 1.us.pool.ntp.org
server 2.us.pool.ntp.org
driftfile /etc/ntp.drift
logfile /var/log/ntp.log


"ntpq" on my local server says:

     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
+conquest.kjsl.c 69.36.224.15     2 u   36   64   37   92.124    4.526   3.050
+rdns02.nexcess. 66.219.116.140   2 u   37   64   37   43.224   -1.739   0.960
*private.ssl119. .CDMA.           1 u   40   64   37   46.856    2.147   4.493

So far so good.

My client's /etc/ntp.conf looks like this:

server 192.168.42.10
driftfile /etc/ntp/drift
logfile /var/log/ntp.log

But when I ask my client to sync up, I get this:

newlaptop-pts/12:~% sudo /usr/sbin/ntpd -d -g -q  
ntpd 4.2.6p1 at 1.2158-o Sat Apr 24 19:01:14 UTC 2010 (1)
addto_syslog: proto: precision = 0.276 usec
event at 0 0.0.0.0 c01d 0d kern kernel time sync enabled
Finished Parsing!!
addto_syslog: ntp_io: estimated max descriptors: 1024, initial socket boundary: 16
addto_syslog: Listen and drop on 0 v4wildcard 0.0.0.0 UDP 123
addto_syslog: Listen and drop on 1 v6wildcard :: UDP 123
addto_syslog: Listen normally on 2 lo 127.0.0.1 UDP 123
restrict: addr 7f000001 mask ffffffff mflags 00003000 flags 00000001
addto_syslog: Listen normally on 3 wlan0 192.168.42.157 UDP 123
restrict: addr c0a82a9d mask ffffffff mflags 00003000 flags 00000001
addto_syslog: Listen normally on 4 wlan0 fe80::4e0f:6eff:fe0d:791 UDP 123
addto_syslog: Listen normally on 5 lo ::1 UDP 123
key_expire: at 0 associd 34262
peer_clear: at 0 next 1 associd 34262 refid INIT
event at 0 192.168.42.10 8011 81 mobilize assoc 34262
newpeer: 192.168.42.157->192.168.42.10 mode 3 vers 4 poll 6 10 flags 0x101 0x1 ttl 0 key 00000000
event at 0 0.0.0.0 c016 06 restart
event at 0 0.0.0.0 c012 02 freq_set kernel -76.751 PPM
transmit: at 1 192.168.42.157->192.168.42.10 mode 3 len 48
auth_agekeys: at 1 keys 1 expired 0
receive: at 1 192.168.42.157<-192.168.42.10 mode 4 len 48
packet: flash header 1420
transmit: at 3 192.168.42.157->192.168.42.10 mode 3 len 48
receive: at 3 192.168.42.157<-192.168.42.10 mode 4 len 48
packet: flash header 1420
transmit: at 5 192.168.42.157->192.168.42.10 mode 3 len 48
receive: at 5 192.168.42.157<-192.168.42.10 mode 4 len 48
packet: flash header 1420
transmit: at 7 192.168.42.157->192.168.42.10 mode 3 len 48
receive: at 7 192.168.42.157<-192.168.42.10 mode 4 len 48
packet: flash header 1420
transmit: at 9 192.168.42.157->192.168.42.10 mode 3 len 48
receive: at 9 192.168.42.157<-192.168.42.10 mode 4 len 48
packet: flash header 1420
addto_syslog: ntpd: no servers found

ntpd: no servers found

Can somebody follow my output and explain to me what's wrong?

Thanks.

--hymie!    http://lactose.homelinux.net/~hymie    hymie at lactose.homelinux.net




More information about the questions mailing list