[ntp:questions] Flash 400 on all peers; can't get ntpd to be happy

Steve Kostecke kostecke at ntp.org
Sun Mar 6 05:49:33 UTC 2011

On 2011-03-06, Ralph <ralph at depth.net> wrote:

> I'm trying to get my ntpd configuration to work and no matter what I
> try nothing seems to work.

Is this in a VM?

> I have numerous servers configured (and have tried various ones) in
> addition to pool servers and still can't get a configuration that
> works cleanly. When I run the peer command, all the servers display a
> condition of 'reject' and a status of 9014. If I run a pstatus on them
> I get a flash value of 400 and results that look like this:


> filtoffset= 67671.8 66534.8 65931.3 65118.0 63317.3 63029.5 62216.4 58156.6,

Your offset for this association is between 58,156 and 67,671
milliseconds. If your other remote time servers are showing a similarly
large offset then ntpd will not use any of them.

> I've tried removing all the restrict statements from my config to
> no avail. When I run peer my reach values are at 377 which I am to
> understand is an indication that things are ok in one respect. Yet I
> seem to be stuck in this status where I'm getting time information but
> not able to get a status that is 'happy'. My rv results always look
> something like this...

What does your 'ntpq -p' look like?

> Now I know the clock on this machine isn't very accurate and I've had
> to set the tinker panic 0 in my config so that ntp can move the clock
> forward by large chunks, but does that prevent my ntpd from working
> cleanly?

You could try disabling that configuration directive.

> I'm on ntp-4.2.2pl-9 on CentOS.

This version is likely much older than you realize; you're using
NTP4 v2.2. The current stable release is ntp-4.2.6p3 (NTP4 v2.6.3). See
http://www.ntp.org/downloads.html or http://support.ntp.org/download for
download links.

Steve Kostecke <kostecke at ntp.org>
NTP Public Services Project - http://support.ntp.org/

More information about the questions mailing list