[ntp:questions] Flash 400 on all peers; can't get ntpd to be happy

David Lord snews at lordynet.org
Sun Mar 6 09:52:43 UTC 2011


Ralph wrote:
> I'm trying to get my ntpd configuration to work and no matter what I try nothing seems to work.
> 
> I have numerous servers configured (and have tried various ones) in addition to pool servers and still can't get a configuration that works cleanly.  When I run the peer command, all the servers display a condition of 'reject' and a status of 9014.  If I run a pstatus on them I get a flash value of 400 and results that look like this:
> 
> assID=39606 status=9014 reach, conf, 1 event, event_reach,
> srcadr=caprica.lerfjhax.com, srcport=123, dstadr=192.168.45.25,
> dstport=123, leap=00, stratum=2, precision=-20, rootdelay=36.652,
> rootdispersion=24.139, refid=209.51.161.238, reach=377, unreach=0,
> hmode=3, pmode=4, hpoll=6, ppoll=6, flash=400 peer_dist, keyid=0, ttl=0,
> offset=67671.865, delay=79.190, dispersion=8.719, jitter=4952.046,

You have a very high initial offset so first I'd shutdown
ntpd then use ntpdate to set the time to a reasonable value
or use 'ntpd -g -q'. With such a large offset you might need
a few tries at setting the clock to within a few milliseconds.

If you have a lot of services running it may also be a good
idea to shut them down first as stepping the clock by large
amounts might cause problems.

What is the value in your current driftfile?

You might want to remove your driftfile (save it somewhere)
and then start ntpd with a clean sheet.


David

> reftime=d11d6afb.4a911fc6  Sat, Mar  5 2011 18:07:55.291,
> org=d11d6cd3.7ddf634b  Sat, Mar  5 2011 18:15:47.491,
> rec=d11d6c8f.dc02f227  Sat, Mar  5 2011 18:14:39.859,
> xmt=d11d6c8f.c7bb6eea  Sat, Mar  5 2011 18:14:39.780,
> filtdelay=    79.19   76.16   78.87   78.78   79.87   77.11   82.28   77.33,
> filtoffset= 67671.8 66534.8 65931.3 65118.0 63317.3 63029.5 62216.4 58156.6,
> filtdisp=      7.81    8.77    9.75   10.74   11.73   12.67   13.62   14.56
> 
> I've tried removing all the restrict statements from my config to no avail.  When I run peer my reach values are at 377 which I am to understand is an indication that things are ok in one respect.  Yet I seem to be stuck in this status where I'm getting time information but not able to get a status that is 'happy'.  My rv results always look something like this...
> 
> assID=0 status=c011 sync_alarm, sync_unspec, 1 event, event_restart,
> version="ntpd 4.2.2p1 at 1.1570-o Sat Dec 19 00:58:16 UTC 2009 (1)",
> processor="i686", system="Linux/2.6.18-194.32.1.el5", leap=11,
> stratum=16, precision=-7, rootdelay=0.000, rootdispersion=30.540,
> peer=0, refid=INIT,
> reftime=00000000.00000000  Wed, Feb  6 2036 22:28:16.000, poll=6,
> clock=d11d6d3b.ea5a48ed  Sat, Mar  5 2011 18:17:31.915, state=1,
> offset=0.000, frequency=8.747, jitter=7.812, noise=7.812,
> stability=0.000, tai=0
> 
> Now I know the clock on this machine isn't very accurate and I've had to set the tinker panic 0 in my config so that ntp can move the clock forward by large chunks, but does that prevent my ntpd from working cleanly?
> 
> I'm on ntp-4.2.2pl-9 on CentOS.
> 
> Thanks in advance to anyone that can offer assistance.




More information about the questions mailing list