[ntp:questions] Flash 400 on all peers; can't get ntpd to be happy

Steve Kostecke kostecke at ntp.org
Sun Mar 6 22:10:03 UTC 2011


On 2011-03-06, Ralph <ralph at depth.net> wrote:

> It is a VM, which I'm sure is why the clock isn't playing nice but I
> haven't found the right solution to fix it...

[snip]

> Are there other tweaks I can do to try to get the clock running
> properly on a VM?

For Xen:

Run 'echo 1 > /proc/sys/xen/independent_wallclock' in domU to allow ntpd
to set the clock.

Add 'xen.independent_wallclock = 1' to /etc/sysctl.conf to make the
setting permanent.

For WMWare:

See http://www.vmware.com/pdf/vmware_timekeeping.pdf

-- 
Steve Kostecke <kostecke at ntp.org>
NTP Public Services Project - http://support.ntp.org/




More information about the questions mailing list