[ntp:questions] Large offset and lots of time resets

Maarten Deen zqrra at kf4nyy.ay
Mon Mar 14 14:56:08 UTC 2011

Maarten Deen <zqrra at kf4nyy.ay> wrote in
news:Xns9E95E2074B3415r68mtnbtdvsdr at 

> hal-usenet at ip-64-139-1-69.sjc.megapath.net (Hal Murray) wrote in 
> news:K4OdnVHgatYT6_jQnZ2dnUVZ_jydnZ2d at megapath.net:
>> In article <Xns9E95DA199C4695r68mtnbtdvsdr at>,
>>  Maarten Deen <zqrra at kf4nyy.ay> writes:
>> ...
>>>23 Feb 20:42:53 ntpd[27664]: time reset +2.421296 s
>>>23 Feb 20:52:05 ntpd[27664]: synchronized to, stratum 2
>>>23 Feb 20:58:31 ntpd[27664]: time reset +2.356457 s
>>>23 Feb 21:04:48 ntpd[27664]: synchronized to, stratum 2
>>>23 Feb 21:14:26 ntpd[27664]: time reset +2.400477 s
>>>This goes on and on and on. And regularly ntp stops having
>>>connection, reach goes to 1 and builds up again. Never that it is a
>>>poll that's been missed, it is always back to 1 as if ntpd has
>>>started itself up again. 
>>>I'm using ntp 4.2.4p4 on a Ubuntu box. Linux kernel 2.6.24.
>>>What's wrong in this setup?
>> My guess is that the clock on your system is broken.  Are you
>> using some sort of power saving that is changing the CPU frequency?
> The computer is a server and is always on. Hardware is an AMD Athlon
> X2 and does lower the CPU frequency in powersaving.
>> Have you tried a different clocksource?
>>   (google for >linux clocksource<)
> First I heard of it, I'll look into it. It is currently set to hpet
> and I see one link that suggests using acpi_pm. I'll try that.

I've tried to change the clocksource but have been unable to. I have 
Ubuntu 10.4.2 and the available_clocksource lists both hpet and acpi_pm. 
Bu setting the clocksource to acpi_pm does not work.

I've now booted with the command "linux   /boot/vmlinuz-2.6.32-29-
generic-pae root=UUID=8e5256d1-0f66-438d-8f9d-d18bdcf7bf7a ro quiet 
splash clocksource=acpi_pm" in grub.cfg, but the current_clocksource is 
still set to hpet.

Am I missing something here?


More information about the questions mailing list