[ntp:questions] enable calibrate?

Dave Hart davehart at gmail.com
Wed Nov 16 00:35:09 UTC 2011


On Wed, Nov 16, 2011 at 00:27, Dave Hart <davehart at gmail.com> wrote:
> FUDGEFAC is 0.1.  The code does not match the docs, which say all
> refclocks are calibrated to match the source marked prefer.  What
> actually is done is:  only if the sys_peer is the ATOM driver (22),
> nudge every other non-ATOM refclock's fudge time1 by -10% of its
> current offset from the system clock.  Over time it will settle down
> with the needed fudge time1 value in effect for each non-ATOM refclock
> to agree with the ATOM driver.
>
> To use it with the current implementation, you must have a PPS source
> and you must configure the ATOM driver for that PPS source (as opposed
> to using, for example NMEA's PPS support), then ntpd will
> automatically determine the fudge time1 value for the remaining
> refclock(s).  You can ensure the clock(s) you want to calibrate aren't
> used by adding noselect to their server lines.  You can montior fudge
> time1 using ntpq's cv ASSOCID/cv &X (X is 1-based index of refclock in
> billboard/as output, ASSOCID would be from ntpq -c as).  Once it's
> settled configure the fudge time1 for each in ntp.conf, remove the
> "enable calibrate" and any "noselect"s added for calibration, and if
> needed revert to your original PPS configuration.  Upon restart, all
> the refclocks should now agree with the PPS.

This implementation was introduced 9-Sep-2007 for 4.2.5p74.  Prior to
that, refclocks could be calibrated against any source.

Cheers,
Dave Hart


More information about the questions mailing list