[ntp:questions] Motorola Oncore UT+ problems

Miguel Gonçalves mail at miguelgoncalves.com
Wed Nov 16 12:29:16 UTC 2011


Hi Tom!

Thanks for you help. I am getting "desperate" here...

On 16 November 2011 11:58, Thomas Laus <lausts at acm.org> wrote:

> My first guess would be that you have a hardware problem with this
> particular Oncore UT+.  Is your Oncore battery good?  I think that the
>

Battery is good. Just checked. I am using the TTL-RS232 conversion circuit
I found at remco.org.


> battery voltage measurement point is pin 1 and the ground reference is
> pin 3.  Does your RS-232 cable have continuity end to end for at least
> pins 1, 2, 3 and 5?  Does your Oncore receiver operate normally when
>

Yes. It starts up OK when using mode 3 but if I restart NTP it doesn't come
up again.


> using any other programs?  The NTP Oncore reference clock driver talks
>

This is connected to a FreeBSD box. I don't have a Windows box to test it.


> a lot during startup.  My last startup looked like this:
>
> Nov 12 17:48:26 mail ntpd[1169]: ntpd 4.2.7p225 at 1.2483-o Thu Oct 27
> 20:01:41 UTC 2011 (1)
> Nov 12 17:48:26 mail ntpd[1170]: proto: precision = 1.676 usec
> Nov 12 17:48:26 mail ntpd[1170]: ONCORE[0]: ONCORE DRIVER -- CONFIGURING
> Nov 12 17:48:26 mail ntpd[1170]: ONCORE[0]: state = ONCORE_NO_IDEA
> Nov 12 17:48:26 mail ntpd[1170]: ONCORE[0]: ONCORE: Can't open SHMEM file
> Nov 12 17:48:26 mail ntpd[1170]: ONCORE[0]: ONCORE: Can't open shmem
> Nov 12 17:48:26 mail ntpd[1170]: ONCORE[0]: state = ONCORE_CHECK_ID
> Nov 12 17:48:27 mail ntpd[1170]: ONCORE[0]: Oncore: Resend @@Cj
> Nov 12 17:48:27 mail ntpd[1170]: ONCORE[0]: @@Cj
> Nov 12 17:48:27 mail ntpd[1170]: ONCORE[0]: COPYRIGHT 1991-1997 MOTOROLA
> INC.
> Nov 12 17:48:27 mail ntpd[1170]: ONCORE[0]: SFTW P/N #     98-P36848P
> Nov 12 17:48:27 mail ntpd[1170]: ONCORE[0]: SOFTWARE VER # 2
> Nov 12 17:48:27 mail ntpd[1170]: ONCORE[0]: SOFTWARE REV # 2
> Nov 12 17:48:27 mail ntpd[1170]: ONCORE[0]: SOFTWARE DATE  APR 24 1998
> Nov 12 17:48:27 mail ntpd[1170]: ONCORE[0]: MODEL #    R5122U1152
> Nov 12 17:48:27 mail ntpd[1170]: ONCORE[0]: HWDR P/N # 5
> Nov 12 17:48:27 mail ntpd[1170]: ONCORE[0]: SERIAL #   R09E3D
> Nov 12 17:48:27 mail ntpd[1170]: ONCORE[0]: MANUFACTUR DATE 0H08
> Nov 12 17:48:27 mail ntpd[1170]: ONCORE[0]:
> Nov 12 17:48:27 mail ntpd[1170]: ONCORE[0]: state = ONCORE_CHECK_CHAN
> Nov 12 17:48:32 mail ntpd[1170]: ONCORE[0]: state = ONCORE_HAVE_CHAN
> Nov 12 17:48:33 mail ntpd[1170]: ONCORE[0]: state = ONCORE_TEST_SENT
> Nov 12 17:48:40 mail ntpd[1170]: ONCORE[0]: GPS antenna: OK
> Nov 12 17:48:40 mail ntpd[1170]: ONCORE[0]: state = ONCORE_INIT
> Nov 12 17:48:43 mail ntpd[1170]: ONCORE[0]: Oncore: Resend @@Cj
> Nov 12 17:48:43 mail ntpd[1170]: ONCORE[0]: state = ONCORE_ALMANAC
> Nov 12 17:48:52 mail ntpd[1170]: ONCORE[0]: Have now loaded an ALMANAC
> Nov 12 17:48:52 mail ntpd[1170]: ONCORE[0]: state = ONCORE_RUN
> Nov 12 17:48:52 mail ntpd[1170]: ONCORE[0]: SSstate = ONCORE_SS_DONE
> Nov 12 17:48:52 mail ntpd[1170]: ONCORE[0]: ONCORE: Detected TRAIM, TRAIM
> = ON
>

My most recent start up (using mode 3):

55881 42800.132 127.127.30.0 ONCORE[0]: ONCORE DRIVER -- CONFIGURING
55881 42800.133 127.127.30.0 ONCORE[0]: state = ONCORE_NO_IDEA
55881 42800.134 127.127.30.0 ONCORE[0]: Input mode = 3
55881 42800.134 127.127.30.0 ONCORE[0]: Initializing timing to Clear.
55881 42800.135 127.127.30.0 ONCORE[0]: HARDPPS Set.
55881 42800.135 127.127.30.0 ONCORE[0]: ONCORE: Can't open SHMEM file
55881 42800.135 127.127.30.0 ONCORE[0]: ONCORE: Can't open shmem
55881 42800.135 127.127.30.0 ONCORE[0]: state = ONCORE_CHECK_ID
55881 42801.121 127.127.30.0 ONCORE[0]: Oncore: Resend @@Cj
55881 42801.502 127.127.30.0 ONCORE[0]: @@Cj
55881 42801.502 127.127.30.0 ONCORE[0]: COPYRIGHT 1991-1997 MOTOROLA INC.
55881 42801.502 127.127.30.0 ONCORE[0]: SFTW P/N #     98-P36848P
55881 42801.502 127.127.30.0 ONCORE[0]: SOFTWARE VER # 2
55881 42801.502 127.127.30.0 ONCORE[0]: SOFTWARE REV # 2
55881 42801.503 127.127.30.0 ONCORE[0]: SOFTWARE DATE  APR 24 1998
55881 42801.503 127.127.30.0 ONCORE[0]: MODEL #    R5122U1152
55881 42801.503 127.127.30.0 ONCORE[0]: HWDR P/N # 5
55881 42801.503 127.127.30.0 ONCORE[0]: SERIAL #   R0AU1M
55881 42801.503 127.127.30.0 ONCORE[0]: MANUFACTUR DATE 1A09
55881 42801.504 127.127.30.0 ONCORE[0]:
55881 42801.504 127.127.30.0 ONCORE[0]: This looks like an Oncore UT with
version 2.2 firmware.
55881 42801.504 127.127.30.0 ONCORE[0]: Channels = 8, TRAIM = ON
55881 42801.504 127.127.30.0 ONCORE[0]: state = ONCORE_CHECK_CHAN
55881 42806.019 127.127.30.0 ONCORE[0]: Input   says chan = -1
55881 42806.020 127.127.30.0 ONCORE[0]: Model # says chan = 8
55881 42806.020 127.127.30.0 ONCORE[0]: Testing says chan = 8
55881 42806.021 127.127.30.0 ONCORE[0]: Using        chan = 8
55881 42806.021 127.127.30.0 ONCORE[0]: state = ONCORE_HAVE_CHAN
55881 42807.494 127.127.30.0 ONCORE[0]: state = ONCORE_RESET_SENT
55881 42808.869 127.127.30.0 ONCORE[0]: state = ONCORE_TEST_SENT
55881 42814.877 127.127.30.0 ONCORE[0]: GPS antenna: OK
55881 42814.878 127.127.30.0 ONCORE[0]: state = ONCORE_INIT
55881 42816.358 127.127.30.0 ONCORE[0]: Setting Posn from input data
55881 42816.359 127.127.30.0 ONCORE[0]: state = ONCORE_ALMANAC
55881 42817.307 127.127.30.0 ONCORE[0]: Posn:
55881 42817.307 127.127.30.0 ONCORE[0]: Lat = N  41.1745292deg,    Long =
W   8.6560922deg,    Alt = 131.84m (432.55ft) GPS
55881 42817.308 127.127.30.0 ONCORE[0]: Lat = N  41deg 10.4718m,   Long =
W   8deg 39.36553m,  Alt =  131.84m ( 432.55ft) GPS
55881 42817.308 127.127.30.0 ONCORE[0]: Lat = N  41deg 10m 28.30s, Long =
W   8deg 39m 21.93s, Alt =  131.84m ( 432.55ft) GPS
55881 42817.364 127.127.30.0 ONCORE[0]: Cable delay is set to 25 ns
55881 42817.367 127.127.30.0 ONCORE[0]: Satellite mask angle set to 0
degrees
55881 42825.043 127.127.30.0 ONCORE[0]: Waiting for Almanac
55881 42830.042 127.127.30.0 ONCORE[0]: Waiting for Almanac
55881 42835.041 127.127.30.0 ONCORE[0]: Waiting for Almanac
55881 42840.040 127.127.30.0 ONCORE[0]: Waiting for Almanac
55881 42845.040 127.127.30.0 ONCORE[0]: Waiting for Almanac
55881 42850.039 127.127.30.0 ONCORE[0]: Waiting for Almanac
55881 42855.038 127.127.30.0 ONCORE[0]: Waiting for Almanac
55881 42860.040 127.127.30.0 ONCORE[0]: Waiting for Almanac
55881 42865.040 127.127.30.0 ONCORE[0]: Waiting for Almanac
(... after a while)
55881 44216.131 127.127.30.0 ONCORE[0]: Waiting for Almanac
55881 44221.131 127.127.30.0 ONCORE[0]: Waiting for Almanac
55881 44226.121 127.127.30.0 ONCORE[0]: Waiting for Almanac
55881 44231.131 127.127.30.0 ONCORE[0]: Waiting for Almanac
55881 44236.131 127.127.30.0 ONCORE[0]: Have now loaded an ALMANAC
55881 44236.131 127.127.30.0 ONCORE[0]: state = ONCORE_RUN
55881 44236.131 127.127.30.0 ONCORE[0]: SSstate = ONCORE_SS_DONE
55881 44237.228 127.127.30.0 ONCORE[0]: ONCORE: Detected TRAIM, TRAIM = ON
55881 44237.228 127.127.30.0 ONCORE[0]: Input   says TRAIM = 1
55881 44237.228 127.127.30.0 ONCORE[0]: Model # says TRAIM = 1
55881 44237.228 127.127.30.0 ONCORE[0]: Testing says TRAIM = 1
55881 44237.228 127.127.30.0 ONCORE[0]: Using        TRAIM = 1
55881 44237.241 127.127.30.0 ONCORE[0]: PPS Offset is set to 0 ns
55881 44237.261 127.127.30.0 ONCORE[0]: Satellite mask angle is 0 degrees
55881 44238.221 127.127.30.0 3530434637.998038528 2011 320 12 17 18 17
rstat   08 dop  0.0 nsat 13,3 traim 1,0,0 sigma 63 neg-sawtooth -40 sat
00080880
55881 44239.221 127.127.30.0 3530434638.998035028 2011 320 12 17 19 18
rstat   08 dop  0.0 nsat 13,3 traim 1,0,0 sigma 63 neg-sawtooth -19 sat
00080880


> If all else fails, remove the receiver battery for at least 30 minutes
> before reinstalling.  Try another program to see if it gets any other
>

I did that but did not wait for 30 minutes... I'll try it.

The strange this is if I start NTP with Oncore mode 3 (hard reset with
position read from the configuration file) it loads the almanac and then
works. If working in mode 3 and if I restart in mode 1 it does not work.

Perhaps I have a bad Oncore receiver. I ordered 3 from China and only one
is working!


> usable data to post on this site.  I have also posted questions to the
> tapr.org timing group mailing list.  There are a lot of Oncore users
> subscribed to that list.
>

I will subscribe to that one.

Thanks again!

Cheers,
Miguel


More information about the questions mailing list