[ntp:questions] Garmin GPS 18 LVC suddenly not syncing, leap?

Dave Hart davehart at gmail.com
Tue Nov 22 00:05:29 UTC 2011


On Mon, Nov 21, 2011 at 23:31, Pete Ashdown <pashdown at xmission.com> wrote:
> Dave Hart <davehart at gmail.com> writes:
>
>>PPS from the microseconds offset.  Which raises my favorite question:
>>which version of ntpd?  (ntpq -crv will say).  I'm guessing it's 4.2.4
>
> #ntpq -crv
> associd=0 status=c618 leap_alarm, sync_ntp, 1 event, no_sys_peer,
> version="ntpd 4.2.6p5-RC1 at 1.2330-o Mon Nov 21 16:46:05 UTC 2011 (1)"

Good stuff.  So much for my guess.

>>> This is the Garmin section of my ntp.conf:
>>> ## LinuxPPS: GPS + PPS
>>> server 127.127.20.1 minpoll 4 prefer
>>> fudge 127.127.20.1 flag1 1 flag2 0 time2 0.600
>>>
>>> Still no dice. Help please?
>
> After more mucking around, I tried this config:
>
> server 127.127.20.1 mode 0 prefer
> fudge 127.127.20.1 flag1 1 flag2 0 time2 0.600

I'd keep the minpoll 4, as it will keep your clock tracking
temperature-induced oscillator drift better than with the refclock
using the default 64s poll interval, and it makes the startup sequence
go faster when debugging.  Adding iburst to your server lines for
network sources will also speed debugging.  Try removing prefer.  I
had missed that the first time around, and it's not needed with a
single NMEA+PPS driver setup.

> I'm getting a >1000ms offset for the GPS vs offnet clocks:
[...]
> Would it be advisable to do "time2 1.600" to compensate or is there a better
> way to do this?

Well, I'd try it.  I'd also suggest ensuring you're using the 3.70
firmware if it is a 18x first.  Fudging time2 to get the initial
offset shown by the NMEA before it engages PPS within 400 msec of the
network peers should ensure the PPS is associated with the correct UTC
second.

Contrary to my earlier guess, your ntpd does use fudge time2 for the
NMEA driver (Juergen's NMEA PPS correlation code is in 4.2.6p5-RC1),
and I'd expect the NMEA driver tally code (first column in ntpq -p
peers billboard) to switch from * to o once the PPS timestamps are
used instead of the NMEA end-of-line timestamps, a few polls after
startup.  Please be sure ntpq --version shows 4.2.6p5 as well.

Cheers,
Dave Hart


More information about the questions mailing list