[ntp:questions] NTP + PPS on Atom motherboards

unruh unruh at invalid.ca
Wed Aug 1 21:58:55 UTC 2012


On 2012-08-01, Chris Albertson <albertson.chris at gmail.com> wrote:
> All Serial ports are spec'd for RS232 voltage levels but many of then will
> still work on TTL levels.    My guess (I'm guessing because you don't say)
> is that you are feeding the serial port a TTL level signal.    The Core 2
> Duo might be fine with this but perhaps the Atom board need "real rs232"
> and you will have the level convert the TTL.

IF that is true, then yes, he would have to level convert and the
procedure of soldering to tiny surface mount legs will do that. On the
other hand almost all serial port chips ( you know the things that the
board manufacturers buy for 5 cents a piece) will handle the TTL levels. 

>
> I also had a problem like yours and it turned out to be the serial cable.
>  I was using about 100 feet of the wrong kind of wire because it was
> already pulled through the walls and down two floors.   I found I needed to
> use a balanced rs422 signal to go that far reliably.   But I ended up
> moving the computer and using a 3 foot cable.  BTW I was using an Atom as
> well and found that I had to give the serial ports on that board a very
> clean in-spec RS232 signal.

Of course that level conversion will slow down the signals as well.
RS232 spec is NOT ns rise times. More like 10s of usec. Again, many
drivers are "out of spec", and are faster.
 
>
> Guessing again, I doubt your ports are "bad" but they might be spec'd for
> rs232 while the core 2 boards are over-spec'd.

You might also want to put on appropriate resistors to terminate the
line. impedence matching is probably not what you want to do, as it can
make the signal far too small (the rs232 or ttl driver cannot put out
enough voltage into 50 or 100 ohms, so instead you use a much higher
impedance and then put up with a slow rise time as the signal bounces
back and forth along the line)


>
>
>
> On Wed, Aug 1, 2012 at 1:46 AM, Hahn, Ron <ron.hahn at fmr.com> wrote:
>
>> Colleagues,
>>
>> I have been working for some time now trying to get four different Asus
>> Atom motherboards to successfully work as a NTP stratum 1 server.  I am
>> using the FreeBSD 8.3 OS with PPS compilation in the kernel, and the
>> ntp-devel port (4.2.7p2?? version ntp).  Thanks to the David Taylor web
>> site, I am using the Sure GPS boards to drive these motherboards and also
>> his MRTG script to monitor these things too.
>>
>> What I am seeing is that the time is off by almost 53,000uS on the MRTG
>> graph and almost 500mS sometimes on the outputs of ntpq -c pe at times.
>>  Other times it is a few uS from PPS.  I have been seeing this on three
>> different boards (D525, D510, and 330 CPU) so this is repeating.  I was
>> thinking this might be the tty port so I have tried both the tty ports and
>> still the same.
>>
>> I have used exactly the same recipe on a Core 2 Duo Tyan server and the
>> times are maximally off by only +4uS/-2uS from PPS.  So I am thinking there
>> is something fundamental wrong with the Atom boards.  I have repeated the
>> experiments with a Pentium 4 server in another location and I am also
>> seeing excellent timekeeping too.  I am thinking that maybe the Atom clock
>> on the board is too consumer for these uses??
>>
>> Has others experienced these difficulties with Atom motherboards as
>> Stratum 1 servers?
>>
>> Thanks,
>>
>> Ron
>> _______________________________________________
>> questions mailing list
>> questions at lists.ntp.org
>> http://lists.ntp.org/listinfo/questions
>>
>
>
>



More information about the questions mailing list