[ntp:questions] Win7: ntpd adjusting time backwards

unruh unruh at invalid.ca
Mon Dec 10 20:17:13 UTC 2012


On 2012-12-10, Jeroen Mostert <jmostert at xs4all.nl> wrote:
> On 2012-12-09 16:10, Jeroen Mostert wrote:
>> On 2012-12-09 16:00, Jeroen Mostert wrote:
>>> I'm going to leave it alone for a bit to see the results after ntpd gets some
>>> time to stabilize. For reference, I've done all of the following so far:
>>>
>>> - Upgraded to ntpd 4.2.7p310.
>>> - Replaced individual "server" lines with a single "pool" line.
>>> - Adjusted power management options within Windows to make processors run at
>>> 100%.
>>> - Updated the BIOS. (Also scratched my nose, which I expect has the same effect.)
>>> - Turned off explicit processor frequency stepping options in the BIOS.
>>> - Used "bcdedit /set useplatformclock on" to force exclusive use of the HPET
>>> (I'm guessing this does nothing at the moment since interpolation isn't used).
>>> - Last but not least, restarted ntpd.
>>>
>> And forgot:
>>
>> - Disabled Teredo tunneling. Likely nothing to do with the performance, but ntpd
>> was logging spurious events for the Teredo interfaces appearing/disappearing.
>> Since I do nothing with IPv6, I saw no reason why this should be on.
>>
> For what it's worth, after all of that, the offset is steadily zigzagging 
> between 27 and 41 ms, which I'm guessing is about the best you can hope for on a 
> Windows machine with Internet sync. There have not been any major time step 
> adjustments.

Since a Linux machine under conditions of use of the internet for time
stamps is capable of sub-millisecond synchronization, this seems really
bad to me. I thought that clock interrupt went at 1ms intervals, and one
should be able to do that well even without interpolation, and with
interpolation even better. 


>
> Thanks to all involved and especially David Taylor for his excellent site on NTP 
> on Windows.
>



More information about the questions mailing list