[ntp:questions] Using PPS

Joshua Small JSmall at daraco.com.au
Thu Dec 27 10:55:16 UTC 2012


Hi,



I built an NTP server with a GPS and PPS as per this guide (exact hardware):



http://open.konspyre.org/blog/2012/10/18/raspberry-pi-time-server/



I got things up and running with the same result as per said guide, before determining that my PPS wasn't wired up correctly.

I fixed that, and now I'm sure it's wired up - it's now detected in dmesg, and ppstest indicates it's running.



As far as any NTP diagnostic I can find goes however, nothing is any different (it feels like I have less drift, but I didn't keep graphs before), which leads me to the question of "how do I know it's working?".



As per the guide, I run this in ntp.conf:

server 127.127.20.0 mode 17 minpoll 3 iburst true prefer
fudge 127.127.20.0 flag1 1 time2 0.496

I can definitely see, in ntpq -p, the GPS_NMEA driver being used.



I can see a related thread here:

http://ml.enneenne.com/pipermail/linuxpps/2009-February/002888.html



Specifically, my googling generally pointed me at looking for PPSSIGNAL in the status, however, it seems that a lack of it (as is my case) is "normal" in many circumstances.



Any advice appreciated.



-Josh.








More information about the questions mailing list