[ntp:questions] timing issue with a HP 58534A

Dave Hart hart at ntp.org
Fri Feb 3 21:00:04 UTC 2012


On Fri, Feb 3, 2012 at 19:41, Mark C. Stephens <marks at non-stop.com.au> wrote:
> Thanks Dave! I removed the fudge time2 line, it was wandering all over the place.
>
> [root at NTP ~]# ntpq -c "rv 0 version"
> version="ntpd 4.2.6p5 at 1.2349-o Thu Feb  2 08:56:24 UTC 2012 (6)"
>
> ntpq> ass
>
> ind assid status  conf reach auth condition  last_event cnt
> ===========================================================
>  1 62329  9024   yes   yes  none    reject   reachable  2
>  2 62330  963a   yes   yes  none  sys.peer    sys_peer  3
>
> ntpq> rv 62329
> associd=62329 status=9024 conf, reach, sel_reject, 2 events, reachable,
> srcadr=GPS_NMEA(0), srcport=123, dstadr=127.0.0.1, dstport=123, leap=00,
> stratum=0, precision=-9, rootdelay=0.000, rootdisp=0.000, refid=GPS,
> reftime=d2d6b591.7878c755  Sat, Feb  4 2012  6:35:45.470,
> rec=d2d6b592.584dc151  Sat, Feb  4 2012  6:35:46.344, reach=377,
> unreach=0, hmode=3, pmode=4, hpoll=4, ppoll=4, headway=0,
> flash=1000 peer_unreach, keyid=0, ttl=0, offset=529.379, delay=0.000,
> dispersion=0.236, jitter=0.035,
> filtdelay=     0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00,
> filtoffset=  529.38  529.42  529.37  529.40  529.37  529.33  529.38  529.32,
> filtdisp=      0.00    0.24    0.48    0.74    0.96    1.20    1.44    1.68
>
> [root at NTP ~]# cat /etc/ntp.conf
> #
> keys /etc/ntp/keys
> trustedkey 1
> requestkey 1
> controlkey 1
>
> # GPS NMEA
> server 127.127.20.0 mode 16 minpoll 4 maxpoll 4  noselect
> #fudge  127.127.20.0 time2 -0.400

The "noselect" explains why your NMEA clock isn't being used.  Remove
that and see how it goes.  Also I notice you're not using fudge flag1
1 to enable PPSAPI -- if you aren't using serialpps.sys, that's
appropriate, but the highest quality PPS timestamps require that
driver and flag1 1.

>
> # GPS PPS
> #server 127.127.22.0 minpoll 4 maxpoll 4 prefer
> #fudge  127.127.22.0 flag3 1
>
> #Inhouse reference
> server 192.168.5.8 iburst maxpoll 9
>
> logconfig =all

I'd have used =allall, but I can't swear =all won't do the same.  You
might check for any warnings at startup suggesting it's not.

> driftfile       /etc/ntp/drift
> enable stats
> statsdir /var/ntp/stats
> statistics loopstats peerstats clockstats

Cheers,
Dave Hart


More information about the questions mailing list