[ntp:questions] NTP on Windows Server 2008 R2

Geir Guldstein dont-spam-geir.guldstein at gmail.com
Wed Feb 8 17:45:54 UTC 2012


On 21.01.2012 19:41, David J Taylor wrote:
> "Geir Guldstein" <dont-spam-geir.guldstein at gmail.com> wrote in message
> news:jfeu9h$6kd$1 at adenine.netfront.net...
>>
>>> 1 - You could try setting the /system/ environment variable
>>>
>>> NTPD_USE_SYSTEM_CLOCK to "1" (or any value)
>>>
>>> as this will force use of the native clock (to force off interpolation).
>>> However, I'm not sure which version of NTP introduced this feature.
>>>
>>> 2 - I'm using NTP 4.2.7p241 which has produced excellent results on
>>> Windows, so you may also like to try that.
>>>
>>
>> Thanks David.
>>
>> Regarding 1: 4.2.6p5 supports NTPD_USE_SYSTEM_CLOCK. However, I don't
>> think that it will make any difference. I see in the source code
>> (nt_clockstuff.c) that the event log message "using Windows clock
>> directly" (which I get in the case where NTP does *not* work properly)
>> indicates that ntpd already has disabled interpolation. Note that this
>> message is not generated in the case where NTP works reasonably well,
>> which means that it does use interpolation in this case.
>>
>> The event log messages indicate that the device driver changes the
>> system clock's resolution:
>> Without device driver installed: "Windows clock precision 15.600 msec,
>> min. slew 6.410 ppm/s"
>> With device driver installed: "Windows clock precision 0.500 msec,
>> min. slew 6.410 ppm/s"
>> In nt_clockstuff.c I see that it is this precision that makes NTP
>> decide to enable or disable interpolation if no environment variables
>> have been set to control it.
>>
>> Regarding 2: Thanks, I will try 4.2.7p241.
>>
>> Geir
>
> Geir,
>
> Once you have 4.2.7p241 installed, it's worth trying with and without
> the variable.
>
> "Windows clock precision 0.500 msec" concerns me, because it suggests
> that the driver is setting the Windows clock to 2 KHz, whereas the
> normal range is up to 1 KHz maximum. Not sure how NTP will behave with a
> clock running at twice the expected speed.....
>
> Cheers,
> David

I have now tested 4.2.7p241 with the device driver installed. I tested 
both with and without NTPD_USE_SYSTEM_CLOCK. I see no difference when 
running this version. I have now opened a support case with the 
device/driver vendor.

Geir

--- Posted via news://freenews.netfront.net/ - Complaints to news at netfront.net ---



More information about the questions mailing list