[ntp:questions] Come back PPS I miss you!

Mark C. Stephens marks at non-stop.com.au
Fri Feb 10 19:58:47 UTC 2012


Looking at the daft timing of this rx, it sends the pps and 400ms later it sends the serial data.

We might have scraped in on 350ms? Haha

So anyway, nmea driver is happily spitting out GPS_NMEA(1) PPS_RELATE_NONE

I'll have a play and maybe replace it with an garmin or something, even if to test my software setup.


Many thanks,
Mark


-----Original Message-----
From: Dave Hart [mailto:davehart at gmail.com] 
Sent: Saturday, 11 February 2012 5:59 AM
To: Mark C. Stephens
Cc: questions at lists.ntp.org
Subject: Re: [ntp:questions] Come back PPS I miss you!

On Fri, Feb 10, 2012 at 12:46, Mark C. Stephens <marks at non-stop.com.au> wrote:
> I have tried everything with my PPS, inverting it in hardware, in 
> software (flag2 1) I just can't get PPS tally to come on.
>
> Today, I restarted and noticed:
> refclock_params: time_pps_setparams: Unknown error: 45
>
> server 127.127.20.1 mode 24 minpoll 4 maxpoll 4 # prefer # noselect 
> #mode 24 # # NMEA serial port, 16 = 9600 baud, 8 = $GPZDA fudge 
> 127.127.20.1 flag1 1 flag2 1 time2 -0.4886745895

serialpps.sys doesn't support triggering on the opposite edge:

	/*
	 * test remaining bits, should only have captureassert,
	 * offsetassert, and/or timestamp format bits.
	 */
	if (mode_in & ~(PPS_CAPTUREASSERT | PPS_OFFSETASSERT |
			PPS_TSFMT_TSPEC | PPS_TSFMT_NTPFP))
		return EOPNOTSUPP;

EOPNOTSUPP is 45.

Cheers,
Dave Hart




More information about the questions mailing list