[ntp:questions] clockstats pausing during ntpq poll

A C agcarver+ntp at acarver.net
Fri Feb 17 19:02:21 UTC 2012


On 2/17/2012 09:23, Dave Hart wrote:
> On Fri, Feb 17, 2012 at 16:44, unruh<unruh at invalid.ca>  wrote:
>> On 2012-02-17, Dave Hart<hart at ntp.org>  wrote:
>>> On Fri, Feb 17, 2012 at 06:06, A C<agcarver+ntp at acarver.net>  wrote:

>>>> What I've noticed is that normally the clockstats is updated once per second
>>>> as the PPS ticks. ?However, during a query by the remote ntpq instance, the
>>>> clockstats file pauses for about one second and then resumes. ?You can see
>>>> it below in a direct copy from the clockstats file. ?There's a missing
>>>> 'tick' at 21828 seconds and one at 21832. ?PPS is most certainly ticking at
>>>> these times. ?It is extremely obvious, when the two terminal windows are
>>>> side by side, that the ntpq poll freezes ntpd.

>>> Round those figures in the 2nd column to whole seconds and you'll note
>>> there are no missing PPS events.  You don't say which ntpq query, so
>>
>> Uh. Yes, there are!. Maybe no the ones he mentions, but there are
>> missing seconds.
>>
>> The rounded figures are
>> 23 24 26 27 28 29 31 32 33
>>      ^           ^
>
> Good catch, I obviously need to get more sleep.

I restarted ntpd and everything seems to be fine now.  This had worked 
very well up until last night when I was getting the missing seconds. 
After restarting ntpd, the condition went away.  I'm watching ntpq poll 
ntpd regularly and the clockstats file is not missing an update anymore.

I'll keep watching it as it runs to see if it comes back.  Now to follow 
the PPM vs. flag3 trail plus finish compiling the fixes to libc (the 
libc error has been found).


More information about the questions mailing list