[ntp:questions] clockvar output from PPS

Alby VA albyva at empire.org
Tue Feb 21 14:50:11 UTC 2012


David:

 With your Sure GPS showing "PPS Clock Discipline", what does your
ntp.conf file look like? I ask, because if I list == server
127.127.22.0 ==
I don't get anything (even though I did the soldering per
http://www.satsignal.eu/ntp/Sure-GPS.htm

But when I list == server 127.127.20.0 == is works just fine.  I also
have
a link of ln -s /dev/cuau0 /dev/pps0 and ln -s /dev/cuau0 /dev/gps0
Is that similar to your setup?

Thanks,

NOTES:
======
godzilla# ntpq -c clockvar
assID=0 status=0000 clk_okay, last_clk_okay,
device="NMEA GPS Clock",
timecode="$GPGGA,144531.000,3903.1142,N,07729.1024,W,
1,6,1.52,111.2,M,-33.4,M,,*61",
poll=3053, noreply=0, badformat=0, baddata=0, fudgetime1=0.000,
stratum=0, refid=GPS, flags=5
godzilla#







On Feb 20, 6:59 am, David Lord <sn... at lordynet.org> wrote:
>
> This is from my system with Sure GPS.
>
> Seems to be similar to yours. I don't have a clue as to stratum and
> refid as this is first time I've used ntpq clockvar.
>
> associd=0 status=00f1 , 15 events, clk_no_reply,
> device="PPS Clock Discipline", timecode=, poll=96503, noreply=300,
> badformat=o, baddata=0, fudgetime1=0.000, stratum=16,refid=80.80.83.98,
> flags=4
>
> associd=0 status=0119 leap_none, sync_pps, 1 event, leap_armed,
> version="ntpd 4.2.... at 1.2349-o Tue Dec 27 09:47:55 UTC 2011 (1)",
> processor="i386", system="NetBSD/5.1_STABLE", leap=00, stratum=1,
> precision=-18, rootdelay=0.000, rootdisp=0.315, refid=PPSb,
> reftime=d2ecad51.c7c9dc25  Mon, Feb 20 2012 11:30:25.780,
> clock=d2ecad57.2e21ead2  Mon, Feb 20 2012 11:30:31.180, peer=65276, tc=4,
> mintc=3, offset=0.000, frequency=-35.663, sys_jitter=0.004,
> clk_jitter=0.003, clk_wander=0.006, tai=34, leapsec=201207010000,
> expire=201212280000
>
> David



More information about the questions mailing list