[ntp:questions] Have Pi, have GPS = low powered NTP server?

E-Mail Sent to this address will be added to the BlackLists Null at BlackList.Anitech-Systems.invalid
Mon Jun 11 18:50:02 UTC 2012


DaveB wrote:
> BlackList
>> ntpq -n -c "lpe" -c "las" -c "rv &0" -c "rv &1" -c "rv &2" -c "rv &3" -c "rv &4"
> OK.....   But you're going to have to unwrap the long lines manually.
> ...
> ***Association value `&0' invalid/undecodable

 Try that with no ampersand on the zero:
ntpq -n -c "rv 0"


> associd=17601 status=8033 conf, sel_reject, 3 events, unreachable,
> srcadr=193.238.80.20, srcport=123, dstadr=0.0.0.0, dstport=0, leap=00,
> stratum=3, precision=-20, rootdelay=16.037, rootdisp=106.339,
> refid=82.219.4.30, reftime=d37aa62b.80023679 Thu, Jun 7 2012 5:01:47.500,
> rec=d37aade1.1bebe777  Thu, Jun 7 2012 5:34:41.109, reach=000,
> unreach=916, hmode=3, pmode=4, hpoll=10, ppoll=10, headway=0,
> flash=1400 peer_dist, peer_unreach, keyid=0, offset=13.885, delay=21.571,
> dispersion=15937.500, jitter=0.000, xleave=0.038,
> filtdelay=    0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00,
> filtoffset=   0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00,
> filtdisp= 16000.0 16000.0 16000.0 16000.0 16000.0 16000.0 16000.0 16000.0

> associd=17602 status=8033 conf, sel_reject, 3 events, unreachable,
> srcadr=194.238.48.2, srcport=123, dstadr=0.0.0.0, dstport=0, leap=00,
> stratum=2, precision=-23, rootdelay=3.540, rootdisp=22.064,
> refid=195.66.241.3,
> reftime=d37aadff.3bc18a97  Thu, Jun  7 2012  5:35:11.233,
> rec=d37aafc1.1b776465  Thu, Jun  7 2012  5:42:41.107, reach=000,
> unreach=915, hmode=3, pmode=4, hpoll=10, ppoll=10, headway=0,
> flash=1400 peer_dist, peer_unreach, keyid=0, offset=-1000.887,
> delay=2019.753, dispersion=15937.500, jitter=0.000, xleave=0.136,
> filtdelay=    0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00,
> filtoffset=   0.00    0.00    0.00    0.00    0.00    0.00    0.00    0.00,
> filtdisp= 16000.0 16000.0 16000.0 16000.0 16000.0 16000.0 16000.0 16000.0

 It looks like you are not getting responses from those last two NTP servers
  (for about the last four days); {I tried them, they seem fine}.

 Can you do a packet capture, and see NTP packets from those servers?

 What do your server and restrict lines look like?  Perhaps needing to add e.g.
restrict source
 (For a server in the conf by name,that perhaps returns multiple A records, like a pool server?}


-- 
E-Mail Sent to this address <BlackList at Anitech-Systems.com>
  will be added to the BlackLists.



More information about the questions mailing list