[ntp:questions] NTP vs RADclock?

unruh unruh at invalid.ca
Mon Jun 11 20:26:26 UTC 2012


On 2012-06-11, Rick Jones <rick.jones2 at hp.com> wrote:
> Rick Jones <rick.jones2 at hp.com> wrote:
>
>> Might go ahead and set rx-usecs to zero.  The Intel drivers have (or
>> at least had) a module parameter called InterruptThrottleRate which
>> tries to be rather clever.
>
>> http://www.intel.com/support/network/adapter/pro100/sb/CS-032516.htm
>
>> I'm not sure just at the moment how that shows-up in the ethtool
>> output though.
>
> Based on reading between the lines of an email reply I've gotten from
> some folks I know at Intel, your interface does indeed have interrupt
> coalescing enabled.  To disable it, set rx-usecs to zero via ethtool -C:
>
> ethtool -C <interface> rx-usecs 0
>

Tried that. Makes no difference to scatter of return time on
the client. Do not know if that means that interrupt coalescence is
still on, or that it makes not difference. The problem appears to be in
the receipt of the packets, not the transmission (although I guess it
could still coalesce interrupts on receipt as well. )



More information about the questions mailing list