[ntp:questions] Failed to test leapsecond's handling

Miroslav Lichvar mlichvar at redhat.com
Thu Mar 8 13:28:07 UTC 2012


On Thu, Mar 08, 2012 at 01:10:02PM +0100, Marco Marongiu wrote:
> But when I graph the time log (see the log target in the makefile), I
> don't see the leap second kicking in. Based on Mills' "The NTP Timescale
> and Leap Seconds"[1], when the leap second kicks in, I'd expect two
> consecutive date command to _appear_ happen at different offset than in
> normal conditions. Unfortunately, that didn't happen, and if I draw a
> line of the accumulated offsets between consecutive runs of the command,
> the line is almost perfectly straight.

Do you see the leap bit enabled in ntptime or adjtimex output? Is the
local timezone UTC? Just to make sure the date commands sets time to
before 0:00 UTC and not some other hour. It would be interesting to
also try "disable kernel" in the ntp.conf.

In a clknetsim simulation with ntp-4.2.6p5 I can see the clock is
correctly stepped by 1.0 second. Here is the ntpd log (in UTC+2
timezone):

http://pastebin.com/ZRi6qv8E

-- 
Miroslav Lichvar


More information about the questions mailing list