[ntp:questions] Trimble Resolution SMT on Ubuntu 12.04

G geng_j at yahoo.com
Mon Mar 26 16:06:05 UTC 2012


I use Trimble Resolution SMT to sync time for a Ubuntu 12.04 server (kernel 3.2.0).

Trimble send NMEA to /dev/ttyUSB1(9600 8N1) on Ubuntu  server
PPS signal connect ACK pin on  /dev/parport0 . Ubuntu load Linux-PPS module( PPS_parport clear_wait=0) to create PPS device /dev/pps0

I use verify the /dev/pps0  using rising edge by "ppstest /dev/pps0"
--------------------------------------------------------------------------------------------
trying PPS source "/dev/pps0"
found PPS source "/dev/pps0"
ok, found 1 source(s), now start fetching data...
source 0 - assert 1332775909.500413150, sequence: 249302 - clear  0.000000000, sequence: 0
source 0 - assert 1332775910.500456132, sequence: 249303 - clear  0.000000000, sequence: 0
source 0 - assert 1332775911.500499213, sequence: 249304 - clear  0.000000000, sequence: 0
-----------------------------------------------------------------------------------------------
To verify the NMEA message , I link /dev/ttyUSB1 to /dev/gps1
-----------------------------------------------------------------------------------------------
#cat /dev/gps1
$GPRMC,153343.000,A,4529.904930,N,07343.904831,W,0.241,325,260312,,,A*6F
$GPGGA,153344.000,4529.905010,N,07343.904879,W,1,3,3.17,12.368,M,-32.087,M,,*5E
---------------------------------------------------------------------------------------------------
I create the /etc/ntp.conf:
-------------------------------------------------------------------------
server 127.127.20.1 mode 17 prefer       # NMEA RMC/GGA 9600bps
fudge 127.127.20.1 time2 0.01

server 127.127.22.0 minpoll 4 maxpoll 4  # PPS ATOM
fudge 127.127.22.0 flag2 0 flag3 1

driftfile /var/lib/ntp/ntp.drift
------------------------------------------------------------------------------
after ntpd run 48hours, ntpq -p:

     remote           refid     st t when poll reach   delay   offset  jitter
==============================================================================
xGPS_NMEA(1)     .GPS.            0 l   44   64  377    0.000  -214.54  25.464
xPPS(0)          .PPS.            0 l   11   16  377    0.000  -174.60   4.981


I have no idea why I got this result . what do I miss for config? by the way , I compile ntpd from source , not using ntpd from Ubuntu.


Thanks for your time to read my question. give me some light please.

regards,

geng


More information about the questions mailing list