[ntp:questions] YEA! My Sure Electronics GPS just arrived.

Ron Frazier (NTP) timekeepingntplist at c3energy.com
Tue Mar 27 00:16:36 UTC 2012


On 3/26/2012 4:00 PM, Alby VA wrote:
> On Mar 24, 10:30 am, "Ron Frazier (NTP)"
> <timekeepingntpl... at c3energy.com>  wrote:
>    
>> Here are my config lines:
>>
>> # COM5 57600 windows lines for testing gps selected as main source -
>> gpgga 57600 baud
>> server 127.127.22.5                        minpoll 3 maxpoll 3
>> # PPS
>> fudge  127.127.22.5 flag2 0      refid PPS
>> # PPS standard polarity
>> server 127.127.20.5                 prefer minpoll 3 maxpoll 3 mode 66
>> # NMEA
>> fudge  127.127.20.5 time2 0.0000 refid GPS1
>> # use WITH PPS
>>
>> Also, why doesn't the PPS show up in my status screen anywhere?  I know
>> it's working, based on the graphs.
>>
>> Sincerely,
>>
>> Ron
>>      
>
>
> Ron:
>
>   Here are my ntp.conf lines I use for my SureGPS running under FreeBSD
> plugged into Com Port 1 ( /dev/cuau0). I also create link (ln -s)
> from  /dev/gps0
> to cuau0.
>
> #
> #
> server 127.127.20.0 mode 18 minpoll 4 maxpoll 4  prefer
> fudge  127.127.20.0 flag1 1 flag3 1 refid PPS
> #
> #
>
>    

Hi Alby,

Thanks for the information.  I tried what you described and now the 
system is working on PPS with only the "20" driver.  But, I'm confused.  
I thought you had to use the "22" driver to get PPS.

I'm trying various options of NTPD_USE_INTERP_DANGEROUS, flag3 on the 
"20" driver, and process priority to see what has any effect.

Sincerely,

Ron

-- 

(PS - If you email me and don't get a quick response, don't be concerned.
I get about 300 emails per day from alternate energy mailing lists and
such.  I don't always see new messages very quickly.  If you need a
reply and have not heard from me in 1 - 2 weeks, send your message again.)

Ron Frazier
timekeepingdude AT c3energy.com



More information about the questions mailing list