[ntp:questions] Using Trimble TSIP under Linux

Kennedy, Paul P.Kennedy at fugro.com.au
Mon Oct 29 12:00:48 UTC 2012


Hi
I did not encounter this, but I would try the following...

ps -e | grep ntpd 

To see if ntp is accidentally running already

sudo chmod 777 /usr/sbin/ntpd 

To make sure the root user (that's the one who runs 'services' has permission to run ntpd. 

My guess is the latter. 

If you get more grief from the atom driver, maybe try the NMEA RMC. Works a treat for me. 

Good luck
Pk


----- Original Message -----
From: questions-bounces+p.kennedy=fugro.com.au at lists.ntp.org <questions-bounces+p.kennedy=fugro.com.au at lists.ntp.org>
To: questions at lists.ntp.org <questions at lists.ntp.org>
Sent: Mon Oct 29 18:45:21 2012
Subject: Re: [ntp:questions] Using Trimble TSIP under Linux

On 29/10/2012 09:44, Kennedy, Paul wrote:
> Dave,
> ntpd will be in /usr/bin or /usr/sbin.   On my pi the /usr/sbin is the
> one in use.  Just copy across your newly built binary and restart with a
> "sudo /etc/init.d/ntp restart"
>
> you can always kill the ntpd process (with a "sudo ps -e | grep ntpd"
> followed by "sudo kill -9 <processname>"), then run the one you bult
> interactively to make sure all is well.  The debug offerings are really
> handy in the interactive mode.
>
> pk

Making progress, Paul, thanks!  I managed to get gpsd to autostart with 
the dpkg-reconfigure, but on ntp it said: "ntp is broken or not fully 
install".  I still says that after I copied the ntp executables from my 
local directory to /usr/bin.  On trying to restart ntp it failed:

pi at raspberrypi ~ $ sudo /etc/init.d/ntp restart
[ ok ] Stopping NTP server: ntpd.
[....] Starting NTP server: ntpd/usr/sbin/ntpd: The ``user'' option has 
been disabled -- built without --enable-clockctl or --enable-linuxcaps
ntpd - NTP daemon program - Ver. 4.2.7p314
USAGE:  ntpd [ -<flag> [<val>] | --<name>[{=| }<val>] ]... \
                 [ <server1> ... <serverN> ]
  failed!

but trying to run ntpd from the command-line it works correctly:

pi at raspberrypi ~ $ sudo /usr/local/bin/ntpd
pi at raspberrypi ~ $

and continues to run after I log out, with excellent PPS support.  I 
took all the defaults when building NTP and set no special options 
myself.  What have I done wrong now!?
-- 
Cheers,
David
Web: http://www.satsignal.eu

_______________________________________________
questions mailing list
questions at lists.ntp.org
http://lists.ntp.org/listinfo/questions


More information about the questions mailing list