[ntp:questions] System time changes only on restarting ntpd service and query about iterating through the sources

unruh unruh at invalid.ca
Fri Sep 7 15:54:01 UTC 2012


On 2012-09-05, Richard B. Gilbert <rgilbert88 at comcast.net> wrote:
> On 9/5/2012 4:47 PM, David Woolley wrote:
>> Arpith Nayak wrote:
>>> Hi all,
>>> I'm running into this problem.  The system time is set to 1970 after
>>> every
>>> system reboot. The first time I enable ntpd it is contacting the ntp
>>> source
>>
>> I was under the impression that NTP time stamps are ambiguous on a time
>> scale that means a system starting with a time in 1970 will never get a
>> correct time.
>>
>>> and getting the updated time. However it is unable to change the system
>>> time immediately. Only after I stop the service and start it again
>>> does the
>>> system time get changed. Has anyone else observed this behaviour? Also is
>>> there any way to iteratively consult the various server addresses
>>> given in
>>> the ntp.conf file?
>>
>> A lot of this probably relates to the system startup scripts, not to
>> ntpd.  As you haven't identified the system, it is a bit difficult to be
>> sure what is going on.
>>>
>
> Without knowing a bit more about the hardware and software involved it's 
> difficult to diagnose.  AFAIK, there should be nothing that requires 
> that your clock defaults to 1970.

Many rtc bios  chipsets report that as their time and date if the clock is
off( battery dead).

>
> If the system defaults the date to 1970, you should be to able override
> the 1970 date by setting the correct year, month, day, time, etc.
>
> If you don't restart the system frequently the date/time should not be a
> big problem.  If you must restart, either set the date/time from a 
> "known good" clock, or learn to live with unreliable date/time stamps.
>
> Best practice is DON'T restart!  If you MUST restart, the startup 
> scripts should get and set the date and time from a trusted source.
>
>
>



More information about the questions mailing list