[ntp:questions] ntp.org's ntpd not to set the hardware clock

Ivan Shmakov oneingray at gmail.com
Thu Sep 13 07:40:23 UTC 2012

>>>>> David Woolley <david at ex.djwhome.demon.invalid> writes:
>>>>> Ivan Shmakov wrote:

 >> I wonder, how do I configure ntpd(8) (as of the Debian Wheezy ntp
 >> package [1]) /not/ to touch the hardware clock?

 > ntpd does not set the hardware clock.  That is done by the Linux
 > kernel, when the clock is disciplined by anything.

	ACK, thanks.  I've suspected something like this may be

 > It's a long time since I looked at that code, but there may be a
 > kernel build time option, and you can always delete the code from the
 > kernel.

	For a one-time task, re-building the kernel doesn't seem like a
	sensible choice.  Perhaps there's a sysctl(8), or a /proc (/sys)
	interface to disable it?  Or perhaps "disable kernel" within
	/etc/ntp.conf will do the thing?

 > I assume you mean the 32kHz RTC, sometimes called TOY.


FSF associate member #7257	http://sfd.am-1.org/

More information about the questions mailing list