[ntp:questions] ntp.org's ntpd not to set the hardware clock

unruh unruh at invalid.ca
Fri Sep 14 20:10:38 UTC 2012


On 2012-09-13, David Woolley <david at ex.djwhome.demon.invalid> wrote:
> Ivan Shmakov wrote:
>> 	I wonder, how do I configure ntpd(8) (as of the Debian Wheezy
>> 	ntp package [1]) /not/ to touch the hardware clock?
>
> ntpd does not set the hardware clock.  That is done by the Linux kernel, 
> when the clock is disciplined by anything.

No. It is done by the kernel when it believes it is synched. 
Thus you need to unset the sync bit. Chrony does that automatically
since it tracks the rtc itself and keeps track of its rate error, (which
the 11 min setting would ruin).

>
> It's a long time since I looked at that code, but there may be a kernel 
> build time option, and you can always delete the code from the kernel.

Or just use adjtimex to tell the kernel that the clock is
unsynchronized. 
adjtimex -S 64
will set the clock as unsynchronized ans wwitch of the 11 min mode. 
(However you probably want to or the 64 with the current status to
preserve other aspects of the current status like leapsecond bits.)

>
> I assume you mean the 32kHz RTC, sometimes called TOY.



More information about the questions mailing list