[ntp:questions] Two issues updating FreeBSD 8.2 with portmaster

David Taylor david-taylor at blueyonder.co.uk.invalid
Thu Sep 27 06:22:35 UTC 2012


On 26/09/2012 19:48, Ron Hahn wrote:
[]
> Tom,
>
> cd /usr/ports
> portsnap fetch update
> portmaster -L             ... to see if ntpd will be updated
> portmaster -a             ... update all packages (subsitute for your
> command for the packages you want to update)
>
> I have seen instances where you have to run a "make deinstall" first
> to get a package to install properly.
>
> Hope that helps,
>
> Ron

Many thanks for your help, Ron, very much appreciated.

The portsnap command appeared to work correctly, although quite why it 
needed to list some 18,000 files on the command-line escaped me!

portmaster -L listed 10 new versions as being available, including NTP 
moving from 4.2.7p255 to 4.2.7p304.

However, then attempting to run portmaster net/ntp-devel I got an error 
perhaps with automake-1.12.4

___________________________________________________
===>  Extracting for automake-1.12.4
=> SHA256 Checksum OK for automake-1.12.4.tar.xz.
===>   automake-1.12.4 depends on file: /usr/local/bin/perl5.10.1 - found
===>  Patching for automake-1.12.4
===>   automake-1.12.4 depends on file: /usr/local/bin/perl5.10.1 - found
===>  Applying FreeBSD patches for automake-1.12.4
File to patch:
No file found--skip this patch? [n]
File to patch:
No file found--skip this patch? [n] y
4 out of 4 hunks ignored--saving rejects to doc/Makefile.in.rej
=> Patch patch-doc::Makefile.in failed to apply cleanly.
=> Patch(es) patch-Makefile.in applied cleanly.
*** Error code 1

Stop in /usr/ports/devel/automake.

===>>> make failed for devel/automake
===>>> Aborting update

===>>> Update for automake-1.11.1 failed
===>>> Aborting update
___________________________________________________

as I did not know the answer to the question: "File to patch:"

Any suggestions?  The original "portmaster net/ntp-devel" ran correctly 
some months back, so I'm somewhat confused as to why I'm now having 
these problems.  At least ntp 4.2.7p255 is continuing to run on that PC.
-- 
Cheers,
David
Web: http://www.satsignal.eu



More information about the questions mailing list