[ntp:questions] ntpd 4.2.6p5 will not synchronize to broadcast servers

Gary Johnson garyjohn at eskimo.com
Thu Apr 25 18:35:11 UTC 2013


Brian Utterback <brian.utterback at oracle.com> wrote:
> I think this is a duplicate of bug 629.
> 
> On 4/24/2013 9:54 PM, Harlan Stenn wrote:
> > Gary,
> >
> > The short answer is "I don't know".  I believe we have successfully used
> > broadcast clients in 4.2.6.
> >
> > Please see if ntp-dev works for you though - if there is a problem there
> > we want to fix that before releasing 4.2.8.
> >
> > And having written the above:
> >
> >   http://bugs.ntp.org/show_bug.cgi?id=2261

Thank you both!  I had found those bug reports earlier, but I didn't
think that wildcards and "255.255.255.255" applied in my case, so I
didn't look closely at either one.  I read the discussions associated
with both last night and applied Dave Hart's suggestion at the bottom of
the bug 629 discussion to add

    interface listen wildcard
    interface listen all

to my /etc/ntp.conf.  Broadcast now works!

I changed the simple test case I posted originally to

    $ ntpd -4 -b -D2 -c /etc/ntp.conf.test &

where /etc/ntp.conf.test contains only those two interface commands.  It
still emits the message

    25 Apr 16:50:38 ntpd[31987]: Unable to listen for broadcasts, no broadcast interfaces available

but broadcast works anyway.

I then added those two interface commands to the top of our normal
/etc/ntp.conf file and broadcast now works in the context of our
application as well.

Does it matter where in /etc/ntp.conf those commands are put?

I will download and install ntp-dev later today and let you know how
that goes.

Thanks again,
Gary



More information about the questions mailing list