[ntp:questions] Help with Oncore PPS - Update

Ron Hahn (EI2JP) ntp-questions at dhco.org
Wed Aug 28 19:36:43 UTC 2013


Hi Charles,

I have disabled the OnCore support in the ntp.conf.  This is what I am 
seeing now.

[root at jupiter /etc/mail]# ntpdate -q ntp0.nl.uu.net
server 193.67.79.202, stratum 1, offset -0.001815, delay 0.05353
28 Aug 20:29:23 ntpdate[23788]: adjust time server 193.67.79.202 offset 
-0.001815 sec
[root at jupiter /etc/mail]# ntpdate -q ntp1.nl.uu.net
server 193.79.237.14, stratum 1, offset -0.002389, delay 0.05852
28 Aug 20:32:06 ntpdate[23861]: adjust time server 193.79.237.14 offset 
-0.002389 sec

So with the OnCore support disabled the ntpd is looking stable again.

I cannot find by vision any syntax error in ntp.conf.

I am running 8.3:

[root at jupiter /etc]# uname -a
FreeBSD jupiter.dhco.org 8.3-RELEASE FreeBSD 8.3-RELEASE #0: Fri Oct 19 
21:30:22 IST 2012 
ronhahn at jupiter.dhco.org:/usr/obj/usr/src/sys/PPSGENERIC  amd64

I am now building a clean 8.4 system which I will be doing controlled 
testing of these things on.

Thank you,

Ron




Charles Swiger wrote:
> Hi, Ron--
>
> On Aug 27, 2013, at 3:02 PM, Ron Hahn (EI2JP)<ntp-questions at dhco.org>  wrote:
>> So the everything is appearing to be wired correctly and ntpd is communicating with the OnCore board.
>
> So far, so good.
>
>> Now the output from ntpq -c pe is not looking so good:
>>
>> [root at jupiter /etc]# /usr/local/sbin/ntpq -c pe
>> remote refid st t when poll reach delay offset jitter
>> ==============================================================================
>> *GPS_ONCORE(0) .PPS. 0 l 3 16 377 0.000 -10099. 1104.94
>> +140.203.204.77 .GPS. 1 u 485 64 200 14.101 2.354 1169.79
>> +193.1.31.66 .PPS. 1 u 102 64 202 11.662 3.258 3589.80
>> +ntp1.oma.be .PPS. 1 u 525 64 200 31.691 0.234 1170.06
>> +ntp2.oma.be .PPS. 1 u 538 64 200 32.711 -0.314 1174.25
>> +ntp0.nl.uu.net .PPS. 1 u 539 64 200 31.572 1.197 1173.40
>> +ntp1.nl.uu.net .PPS. 1 u 142 64 4 29.731 -8965.1 8597.68
> [ ... ]
>
> Your reachability scores look very bad; you're not getting replies to most of your queries.
> Sometimes that indicates a broken NAT/firewall device trying to keep state for NTP traffic.
>
> Just taking a look at the last two hosts, notice the huge variance in offsets, but they're fine here:
>
> % ntpdate -q ntp0.nl.uu.net
> server 193.67.79.202, stratum 1, offset -0.015699, delay 0.18793
> 27 Aug 15:20:00 ntpdate[59866]: adjust time server 193.67.79.202 offset -0.015699 sec
>
> % ntpdate -q ntp1.nl.uu.net
> server 193.79.237.14, stratum 1, offset -0.014814, delay 0.18111
> 27 Aug 15:20:05 ntpdate[59868]: adjust time server 193.79.237.14 offset -0.014814 sec
>
>> I can not get any outputs from the ntpdc command so this is to be fixed still. Maybe this is a clue?
> [ ... ]
>> The ntpdc command is not giving me any output:
>>
>> [root at jupiter /etc]# /usr/local/sbin/ntpdc -c sysi
>> localhost: timed out, nothing received
>> ***Request timed out
>
> If ntpd is running, then I'd guess you have misconfigured firewall rules which block traffic via loopback on localhost.  Perhaps could be something wonky with IPv6 if you've got that enabled / preferred by default?
>
> Does: "ntpq -pcrv localhost" or "ntpq -pcrv 127.0.0.1" do any better?
>
>> The other datas:
>>
>> In my ntpd.log:
>>
>> ------------------
>> 27 Aug 22:31:25 ntpd[93874]: ntpd 4.2.7p364 at 1.2483-o Mon Apr 22 18:07:31 UTC 2013 (1): Starting
>> 27 Aug 22:31:25 ntpd[93874]: Command line: /usr/local/sbin/ntpd -c /etc/ntp.conf -A -g -N -p /var/run/ntpd.pid -l /var/log/ntpd.log
>> 27 Aug 22:31:25 ntpd[93875]: proto: precision = 1.955 usec (-19)
>> 27 Aug 22:31:25 ntpd[93875]: line 55 column 1 syntax error, unexpected T_String, expecting $end
>> 27 Aug 22:31:25 ntpd[93875]: syntax error in /etc/ntp.conf line 55, column 1
>
> Your /etc/ntp.conf has a syntax error...?
>
> Regards,

-- 
Ron Hahn, EI2JP
Dublin, Ireland

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.



More information about the questions mailing list