[ntp:questions] Silly question.

DaveB spam.goes at nowhere.com
Mon Dec 16 12:36:49 UTC 2013


In article <K7KdnW2T7OnhKDDPnZ2dnUVZ_rOdnZ2d at supernews.com>, 
lausts at acm.org says...
> 
> If you built it from a port, it gets installed in /usr/local/bin.  The
> default system built ntp programs go in /usr/bin or /usr/sbin.
> 
> Tom

Thanks Tom (and the rest of the collective)..

That's exactly were it was hiding (in plain sight!)

I've added override variables in /etc/rc.conf to point to both ntpd and 
ntpdate that are located in /usr/local/bin.

I also see there is a companion ntpq in there too, but in 
/etc/default/rc.conf  There is no "default" path set to that program.

For now, I've a commented out line in /etc/rc.conf
# ntpq_program="/usr/local/bin/ntpq"

Commented out as I don't know if that will work.  (I'm still re-
educating myself with the neuances of BSD, it's been a while.)

Ntpdate was only run the one time to yank the box to current date-time, 
but ntpq is of course run as needed to see what's happening, often over 
a sshd session, if I get an email from someone wondering why something 
appears to have gone awry, on a yet to be reinstated webpage.

For now, having stopped ntpd, applied the changes I need in /etc/rc.conf 
then restarted ntpd, sure enough, the Meinberg monitor program on the 
Windows PC accross the room now reports the BSD box is running ntpd 
4.2.6p5 at 1.2.3.4.9 built on December the 14th at 10:15 UTC, that is 
indeed the day and time I built it.  So...  So far, so good.

Comments would be appreciated re setting the path to ntpq, but for now, 
all's working, while I figure out what next to do...

Best Regards.

Dave B.



More information about the questions mailing list