[ntp:questions] NTP client syncs successfully with NTP server within local network but not with the NTP pool servers

David Taylor david-taylor at blueyonder.co.uk.invalid
Wed Jan 9 08:58:51 UTC 2013


On 09/01/2013 05:41, Arpith Nayak wrote:
> I am using ntp 4.2.6p5 on linux.
>
> I setup an NTP server on a machine in another subnet and tried to sync
> my machine with the server and it works well. But when I try to use
> the pool.ntp.org servers (I tried 0.pool.ntp.org, 1.pool.ntp.org, etc.
> and just pool.ntp.org servers), it does not sync.
[]
> Adding ntpq -p data:
>
> [Thu Feb 10 12:55:51 root at root-ubuntu:~]# ntpq -p 0.pool.ntp.org
>
>       remote           refid      st t when poll reach   delay   offset  jitter
> ==============================================================================
> *64.147.116.229  .ACTS.           1 u  151 1024  377    2.439   -0.632   0.052
> +131.107.13.100  .ACTS.           1 u  879 1024  377   27.853    1.041   0.539
> -time.nrc.ca     132.246.11.231   2 u  989 1024  377   86.821   -4.132   8.778
> -time1.chu.nrc.c 209.87.233.52    2 u   53 1024  377  109.221    3.153   9.377
> +dense.utcc.utor 128.100.200.166  2 u   88 1024  377   64.115   -1.841   0.454
> -dns4.utoronto.c 128.100.103.253  2 u  167 1024  377   65.252  -43.422  56.093
=================

Arpith, why do you think your own PC is not syncing?  What is the output 
from "ntpq -p" on your own PC?  (Your ntpq command to a remote PC is 
working).  Then see:

   http://support.ntp.org/bin/view/Support/TroubleshootingNTP

Paragraph: 9.4. Checking ntpd 's status.

Perhaps you need to set the coarse time before starting NTP, or start 
NTP with the flag which allows it to step the time at startup.  I think 
that's "-g".  See, for example:

   http://www.freebsd.org/cgi/man.cgi?query=ntpd&sektion=8
-- 
Cheers,
David
Web: http://www.satsignal.eu



More information about the questions mailing list