[ntp:questions] 1s offset

folkert folkert at vanheusden.com
Tue Mar 5 20:32:57 UTC 2013


Something odd is happening.
I have an old Garmin 18x LVC, a couple of years old and one I bought a
couple of weeks ago.
The one from a couple of weeks ago has the most recent firmware.
The older one only returns one sentence (GPMRC if I remember correctly),
the new one has factory default settings and returns a couple of them.
Now when I run either 4.2.6p5 or dev-4.2.7p359, I always get an offset
of ~1s.
Both systems are configured to use NMEA + PPS synchronization.
If I use 4.2.5p158 instead, the synchronization is perfect, on both
As the older garmin has much older firmware and the new garmin the most
recent one (3.80 iirc), I don't think it is firmware issue. Also I tried
the new garmin with only 1 nmea sentence but that didn't help.
The 4.2.5p158 ntp version does not seem to do ipv6? So that is..., a bit

Any ideas?

Folkert van Heusden

www.TrustedTimestamping.com is a service that enables you to show that
at a certain point in time, you had access to a hash-value reflecting
the contents of a file (this file can be a word document, a jpeg
image, everything).
Phone: +31-6-41278122, PGP-key: 1F28D8AE, www.vanheusden.com

More information about the questions mailing list