[ntp:questions] 1s offset

David Taylor david-taylor at blueyonder.co.uk.invalid
Wed Mar 6 16:05:36 UTC 2013

On 05/03/2013 20:32, folkert wrote:
> Hi,
> Something odd is happening.
> I have an old Garmin 18x LVC, a couple of years old and one I bought a
> couple of weeks ago.
> The one from a couple of weeks ago has the most recent firmware.
> The older one only returns one sentence (GPMRC if I remember correctly),
> the new one has factory default settings and returns a couple of them.
> Now when I run either 4.2.6p5 or dev-4.2.7p359, I always get an offset
> of ~1s.
> Both systems are configured to use NMEA + PPS synchronization.
> If I use 4.2.5p158 instead, the synchronization is perfect, on both
> systems.
> As the older garmin has much older firmware and the new garmin the most
> recent one (3.80 iirc), I don't think it is firmware issue. Also I tried
> the new garmin with only 1 nmea sentence but that didn't help.
> The 4.2.5p158 ntp version does not seem to do ipv6? So that is..., a bit
> unfortunate.
> Any ideas?
> Folkert van Heusden


Agreed that it's unlikely to be a firmware issue, but there is an 
interesting graph here:




which shows that the end of the NMEA sentence may be well over 0.5 s 
after the  PPS, and hence into the next second.  Could it be that:

(a) 4.2.5p158 looks for the start of the data, not the end


(b) you haven't specified the appropriate time offset value (fudge 
field) for the serial data for the other two versions of NTP?

Just my initial thoughts.
Web: http://www.satsignal.eu

More information about the questions mailing list