[ntp:questions] NTP not syncing

David Woolley david at ex.djwhome.demon.invalid
Sat Nov 2 17:22:33 UTC 2013


On 02/11/13 15:33, antonio.marcheselli at gmail.com wrote:
>      server 127.127.1.0
>      fudge 127.127.1.0 stratum 10

Remove the above.  Although it seems to be ignoring them at the moment, 
they are nearly always wrong, and are incompatible with tos orphan.

>      tos orphan 4

Caution 4 is rather low, but that is not relevant here as you are not in 
orphan mode.


> hmode=3, pmode=4, hpoll=6, ppoll=6, flash=00 ok, keyid=0, ttl=0,

> filtoffset= -7188.7 -7186.2 -7183.9 -7181.9 -7179.7 -7177.5 -7175.1 -7173.2,

You seem to be diverging at -34.6 ppm.  That's not too inconsistent with:
>
>   2 Nov 15:02:02 ntpd[5306]: frequency error -527 PPM exceeds tolerance 500 PPM

i.e. 500 + 27 ~= 534.

It looks like the software clock is outside the usable range.  What's 
more worrying, if it sometimes works, is that it varies from time to 
time enough to put it just inside the useful range.

The first bit you can deal with by using the kernel time control utility 
(names vary) to correct the frequency in steps of 100 ppm.  However, if 
the frequency is not stable, that will not give you good timekeeping.

>
> Could someone please help? I can add a forth server if needed, I also understand that it would be recommended to use the iburst parameter.

Adding a Scottish server, or even a fourth one from elsewhere won't help 
as you already have three servers that agree with each other.

As it should have stepped before the error reached 7 seconds, it is also 
possible that they disabled stepping.  If the drift file value is way 
out, that might cause some problems in getting lock.  It will also tend 
to prevent use of the higher quality kernel time discipline.



More information about the questions mailing list