[ntp:questions] NTP not syncing

unruh unruh at invalid.ca
Sat Nov 2 23:37:14 UTC 2013


On 2013-11-02, antonio.marcheselli at gmail.com <antonio.marcheselli at gmail.com> wrote:
>
>> 
>> >  You might check whether the system boards do power saving by changing cpu clock frequencies. That throws ntpd. 
>> 
>> > 
>> 
>> 
>> 
>>   Some more info in the same vein. This issue has been seen with Supermicro boards as far back as 2006.
>> 
>>  Check out the following to see if your linux is configured to manage cpu stepping. If you don't see it there, disable it in the BIOS.
>
>
>
> This is interesting.
> Are you saying that if the CPU is changing frequency and Linux is not configured to handle it, ntpd will see the clock changing wildly?

How can it "see it"? It is the clock that determines the instructions
running time, and there is no other clock to tell you what that clock is
doing. It is like using the local clock as a refclock driver. It always
finds that the clock is ticking at one second per second exactly, no
matter what it is doing. 

>
> Thanks,
> Antonio



More information about the questions mailing list