[ntp:questions] NTP not syncing

Antonio Marcheselli puppa at me.la
Sun Nov 3 01:30:19 UTC 2013


>
> My guess is you're not meant to do it that way but then I'm
> no expert at configuring debian.

As pointed out by John, it's how the manufacturer implemented the system.

>
> Are you completely unable to resolve ip address to hostname
>
> eg.
>
>      $ host 130.88.200.4
>      4.200.88.130.in-addr.arpa domain name pointer dir.mcc.ac.uk.

Yes, I get a timeout.

Sorry but I can't really amend network settings. The network on this 
machine is being used for critical secure packages and anything wrong 
would have bitter consequences.

I appreciate that using pools would be better but in my case I'm happy 
with just the IP numbers. If/when the servers go offline I'll change the 
configuration.

But thanks for your input anyway

> You also probably need to stop ntpd if it's not synced with
> a low offset of a few ms, delete the driftfile, run ntpdate
> then restart ntpd.

Which I did an hour-ish ago.

Stopped ntpd, deleted drift file, amended configuration as you suggested 
as below:

     server 158.43.128.66 iburst
     server 81.168.77.149 iburst
     server 130.88.200.4 iburst
     restrict 127.0.0.1
     restrict 169.254.1.1 mask 255.255.0.0 nomodify
     tos orphan 6
     driftfile /status/etc/ntp/ntp.drift
     logfile /var/log/ntp.log
     multicastclient
     broadcastdelay 0.008
     enable monitor

Now after just an hour the drift is -30, and all offsets are near zero.

Same server, same network, what happened??

Antonio



More information about the questions mailing list