[ntp:questions] NTP not syncing

Antonio Marcheselli puppa at me.la
Fri Nov 8 23:41:34 UTC 2013


On 03/11/2013 01:24, Antonio Marcheselli wrote:
>>    That's about it. One of the assumptions made by NTP is that it is
>> running at a fixed clock speed (or rather that the system 'clock
>> source' is). So when that sources frequency is altered for power
>> saving or performance enhancement (you can configure both) , it will
>> be seen as slowing or speeding up  when compared with the configured
>> servers timestamps. If for instance, after booting and ntp startup the
>> cpu goes idle, then the frequency could be lowered, causing the clock
>> source to slow down, causing your problem. In older implementations I
>> believe that the cpu frequency lowering also caused the clock source
>> to slow (ex. the TSC was directly linked to the cpu frequency) but I
>> believe that some newer cpus keep the clock source running at a
>> constant frequency and just modify the execution units frequency to
>> avoid this issue.
>
> Cheers for that, I'll have a look.

The server with the drift file at 450 was rebooted and the drift went to 
500+. Restarting the NTP is not helping.
I definitely need to look at the hardware.

I'd like to thank you all, I have investigated on NTP for some time now 
and nobody was able to explain things clearly as you did.

Thank you guys!

Question related to this topic. I am told that I can enable the HPET on 
the motherboard and I can tell linux to use it.

The file I am trying to amend is 
/sys/devices/system/clocksource/clocksource0/available_clocksource

I have a I/O error when I try to save. The folder and the file have RW 
permissions, any idea on why I can't amend it?

Thanks
Antonio



More information about the questions mailing list