[ntp:questions] NTP not syncing

Antonio Marcheselli puppa at me.la
Sat Nov 23 16:33:55 UTC 2013


>>>
>>>> You might check whether the system boards do power saving by changing cpu clock frequencies. That throws ntpd.
>>>

>>>   Some more info in the same vein. This issue has been seen with Supermicro boards as far back as 2006.
>>> Check out the following to see if your linux is configured to manage cpu stepping. If you don't see it there, disable it in the BIOS.

Hello,

Well, I have great news.
I happened to be on site and found that both servers with NTP problems 
had the Intel CPU stepping enabled in the BIOS.
I disabled it and it now works, the drift file is steady - even though 
on some large amount, 250 on one and 160 on another.

The third server which always worked does not have any power saving 
features (older motherboard) and the drift is stable at around 21.

So far so good then. I must thank you all for the massive help received 
on this forum, it's been a honour to talk with you guys.

I'll post an update to confirm that all is good!

Another quick question: does the "restrict" parameter prevent any other 
server from using the server's NTP as a source?

If I use "restrict 192.168.1.10" does that mean that only 192.168.1.10 
can use that NTP as a source?

Thanks again

Tony



More information about the questions mailing list