[ntp:questions] NTP Bug 2328 - Vista/Win7 time keeping inaccurate and erratic

David Taylor david-taylor at blueyonder.co.uk.invalid
Fri Nov 29 20:59:47 UTC 2013


On 28/11/2013 13:42, Martin Burnicki wrote:
> David Taylor wrote:
>> I'm not sure whether we still have a route into Microsoft to get the
>> adjustment quantisation fixed - it would certainly be helpful.
>
> Indeed, and providing an API which could be used to tell Windows that a
> leap second has been scheduled would make everything perfect. ;-)
>
>> Referring to your graphs, I took a GPS/PPS synced Raspberry Pi along to
>> the downstairs network, and made Win-7/64 PC Molde take its preferred
>> reference NTP server instead of an stratum-1 server over Wi-Fi.  What a
>> dramatic improvement!
>>
>>    http://www.satsignal.eu/mrtg/molde_ntp-b.html
>>
>> Averaged jitter has dropped from around 3 milliseconds to just under 1
>> millisecond (likely a Win-7 resolution limitation), and the offset from
>> a spikey +/- 5 milliseconds to a much smaller value as can be seen from
>> the graph.  Now I have to think about installing Ethernet cable
>> everywhere!  <G>
>
> That is exactly what I would have expected.
>
> Martin

I've now put the graphs into a short, possibly developing note, here:

   http://www.satsignal.eu/ntp/Win-7-Wi-Fi-vs-LAN.html

Maybe I should add a configuration diagram, although I feel the message 
is clear enough already.

Thanks for prompting me to look into this.

-- 
Cheers,
David
Web: http://www.satsignal.eu



More information about the questions mailing list