[ntp:questions] NTP NMEA driver

mike cook michael.cook at sfr.fr
Thu Feb 6 11:36:54 UTC 2014

Le 6 févr. 2014 à 12:05, Charles Elliott a écrit :

> The config file should have this format
> server mode 65 minpoll 4 maxpoll 4 prefer
> fudge time2 0.363352  
> fudge flag4 0

You can happily put the fudge factors on the same line if you wish. The OP left his mode at 0, thus accepting all NMEA incoming messages at 4800baud. The driver uses the first received IIRC.  Your mode bits are just selecting a specific message and a higher transmission rate. Flag 4, 0 is the default .
I dont think the root of the issue is there. 

 Once he has verified that his 1PPS signals are actually creating interrupts, he might try using the ntpd PPS disciplining rather than the kernel, to narrow down the possibilities. Also if he has access to public servers over the net, configure the Atom driver just to verify the 1PPS viability and chose a pool server as a preferred source of the date/time.

On a personal note, I have stopped using the NMEA stream from my receivers and use just the 1PPS with the Atom driver, and have nearby S2 servers preferred to get the date/time. Of course that only works if my network is running. 

More information about the questions mailing list