[ntp:questions] enable pps not working from ntp.conf

Brian Inglis Brian.Inglis at SystematicSw.ab.ca
Wed Jan 8 15:32:21 UTC 2014


On 2014-01-08 02:55, David Lord wrote:
> Dennis Golden wrote:
>> I have searched to find an answer to this problem with no success. I am using the oncore clock (127.127.30.0) and have included "enable pps" in ntp.conf, but I get the following in /var/log messages:
>>
>> line 59 column 8 syntax error, unexpected T_String
>> syntax error in /etc/ntp.conf line 59, column 8
>>
>> I can use ntpdc to set this option with no problem.
>
> Hi
>
> I have an oncore??? that I've never tried.
>
> My sources for ntp-dev-4.2.7p401 don't seem to have any code
> for oncore.pps.n whilst it is present in 4.2.6p5.

ntpd/refclock_oncore.c is there thru latest dev p409.


> My couple of suggestions are:
>
> (1) symlink from the serial port device to /dev/oncore.pps.n
...and /dev/oncore.serial.N


set up the Oncore in NMEA mode and...
> (2) try the Atom + nmea drivers as alternative
>
> The oncore driver seems to allow a selectable skew so that
> several pps devices can run at the same time so you'd lose
> that functionality.
...but that is not required for a single device

-- 
Take care. Thanks, Brian Inglis


More information about the questions mailing list