[ntp:questions] enable pps not working from ntp.conf

David Taylor david-taylor at blueyonder.co.uk.invalid
Wed Jan 8 17:46:26 UTC 2014


On 07/01/2014 16:55, Dennis Golden wrote:
> I have searched to find an answer to this problem with no success. I am
> using the oncore clock (127.127.30.0) and have included "enable pps" in
> ntp.conf, but I get the following in /var/log messages:
>
> line 59 column 8 syntax error, unexpected T_String
> syntax error in /etc/ntp.conf line 59, column 8
>
> I can use ntpdc to set this option with no problem.
>
> Any ideas?
>
> TIA,
>
> Dennis

Likely it's not related, but I was just playing with a new system 
(Raspberry Pi) and I had told NTP that a leap file was present, when I 
hadn't yet created it.  This is copying the ntp.conf from one system to 
another.  NTP worked, except the PPS didn't work when the system booted. 
  Restart NTP and the PPS worked perfectly.  I didn't put two and two 
together until I added the leap-second file, and NTP started correctly 
at boot time.  The reference was right at the end of ntp.conf

So this suggests that NTP can parse so far down ntp.conf and get those 
things working, but when it finds an error, it stops other things 
working.  So maybe your error was causing a similar effect.  This with 
ntp 4.2.7p410 on Raspberry Pi with a derivative of Debian Wheezy, I believe.
-- 
Cheers,
David
Web: http://www.satsignal.eu



More information about the questions mailing list