[ntp:questions] enable pps not working from ntp.conf

David Lord snews at lordynet.org
Sat Jan 11 13:54:38 UTC 2014


Dennis Golden wrote:
> On Wed, 08 Jan 2014 17:46:26 +0000, David Taylor wrote:
> 
>> On 07/01/2014 16:55, Dennis Golden wrote:
>>> I have searched to find an answer to this problem with no success. I am
>>> using the oncore clock (127.127.30.0) and have included "enable pps" in
>>> ntp.conf, but I get the following in /var/log messages:
>>>
>>> line 59 column 8 syntax error, unexpected T_String
>>> syntax error in /etc/ntp.conf line 59, column 8
>>>
>>> I can use ntpdc to set this option with no problem.
>>>
>>> Any ideas?
>>>
>>> TIA,
>>>
>>> Dennis
>> Likely it's not related, but I was just playing with a new system 
>> (Raspberry Pi) and I had told NTP that a leap file was present, when I 
>> hadn't yet created it.  This is copying the ntp.conf from one system to 
>> another.  NTP worked, except the PPS didn't work when the system booted. 
>>   Restart NTP and the PPS worked perfectly.  I didn't put two and two 
>> together until I added the leap-second file, and NTP started correctly 
>> at boot time.  The reference was right at the end of ntp.conf
>>
>> So this suggests that NTP can parse so far down ntp.conf and get those 
>> things working, but when it finds an error, it stops other things 
>> working.  So maybe your error was causing a similar effect.  This with 
>> ntp 4.2.7p410 on Raspberry Pi with a derivative of Debian Wheezy, I believe.
> 
> Thanks to all for your responses. I still don't understand why enable pps using
> ntpdc appears to work and shows up in the logs, but I'm not sure it does anything
> from looking at the source (ntp-4.2.6p5). Since consensus says that it's not
> supported, I'm not going to worry about it. Correlating the information from other
> servers, it appears that pps is working.

On NetBSD-6 my "Sure" evaluation board and ntp-dev-4.2.7p401
using atom with nmea drivers -

$ ntpq -p
remote        refid   st t poll reach  offset jitter
-GPS-NMEA(2)  .GPSb.   7 l   64   377  -6.821  8.756
oPPS(2)       .PPSb.   0 l   16   377  -0.001  0.004
.....

$ ntpq -c rv
....., sync_pps, .....

$ ntptime
.....
   offset -0.893 us, .....
   maximum error 402500 us, estimated error 1 us,
   status 0x2107 (PLL,PPSFREQ,PPSTIME,PPSSIGNAL,NANO),
.....

So it is clear enough for me that PPS is working.


David

> 
> Regards,
> 
> Dennis



More information about the questions mailing list