[ntp:questions] need option to ignore 'leap not in sync error'

William Unruh unruh at invalid.ca
Thu Jan 16 17:38:27 UTC 2014


On 2014-01-16, Maarten Wiltink <maarten at kittensandcats.net> wrote:
> "Sanal, Arjun (NSN - IN/Bangalore)" <arjun.sanal at nsn.com> wrote in message
> news:592C0209968E17479F27087D92C1F7E414E051 at SGSIMBX006.nsn-intra.net...
>
> [...]
>> The setup is a blade server, which has one master blade server which
>> runs the ntp server. All other blades sync the time from this master.
>> The master itself gets it time from a higher ntp server. The problem
>> is when the master says that it is not suitable for synchronization,
>> the client blades shouldn't reject it. If they, do all the blades
>> will end up with different time.
>
> Configure the local clock as a source at high stratum on the master.
> "server 127.127.1.0 stratum 10"
>
> People will now fall all over you, and me, yelling that this is
> anathema, but you have explained to my satisfaction what you want,
> and this is how you do it.

I would not fall all over you. This seems to be precisely the case for
which the "local" directive was designed. 
It IS inappropiate to use local as a general feature, including on pure
clients, as is done in some config files of some distros. 

There are I believe some other options with newer version of ntp (orphan
mode?) as well, but I do not know the details. 

>
> Groetjes,
> Maarten Wiltink
>
>



More information about the questions mailing list