[ntp:questions] strange ntptrace behaviour on different ntp-clients

Brian Utterback brian.utterback at oracle.com
Thu Jan 23 14:04:01 UTC 2014


What version of Solaris were you using? If you were using Solaris 10, 
then the ntptrace command is the old version that uses the ref field as 
the IPv4 address of the server. Since it does not rely on control or 
private packets it can work even if "noquery" was specified on one of 
the servers in the chain. Since the ref field cannot hold an IPv6 
address, the ntptrace program was changed in NTP version 4 to use 
control packets to find out the IP address of each server. This works 
with both IPv4 and IPv6, but requires all the servers to allow control 
packets.

On 1/23/2014 2:52 AM, ardi wrote:
> I have tried to set up 3-level for ntp-setting:
>
> xx.xx.xx.aa stratum 1 server (taking time from GPS)
> -------------------------------------------------------
> xx.xx.xx.b1
> xx.xx.xx.b2 are stratum 2 servers acting as ntp-servers
> --------------------------------------------------------
> xx.xx.xx.c1
> xx.xx.xx.c2 are stratum 3 ntp-clients
> --------------------------------------------------------
>
>
> NOTE: all clients have stratum 2 servers defined as ntp-server time sources.
>
> a)
> when doing ntptrace from  a client (without parameter),
> I am getting Timed out :
>
> NOK:
> client.c1 # ntptrace
> localhost: stratum 3, offset -0.000033, synch distance 0.000230
> xx.xx.xx.b1: timed out, nothing received
> ***Request timed out
> client.c1 #
>
> NOK:
> client.c1 # ntptrace xx.xx.xx.b1 #towards stratum 2 server
> xx.xx.xx.b1: timed out, nothing received
> ***Request timed out
>
> OK:
> client.c1 # ntptrace xx.xx.xx.aa #stratum 1 ntp-server
> aa.dfdsf.sdff.lab: stratum 1, offset -0.000002, synch distance 0.000000, refid 'GPS'
> client.c1 #
>
> doing it from another client, which is solaris:
>
> OK:
> bash-3.00# ntptrace
> localhost: stratum 3, offset 0.000026, synch distance 0.01694
> xx.xx.xx.b1: stratum 2, offset 0.000160, synch distance 0.00133
> aa.dfdsf.sdff.lab: stratum 1, offset 0.000315, synch distance 0.00021, refid 'GPS'
> bash-3.00#
>
> NOTE:
> for xx.xx.xx.b1 the first line of ntp.conf is the following:
>
> restrict default noquery nomodify notrap
>
> b)
> when i remove noquery parameter on stratum 2 ntp-server xx.xx.xx.b1 and restart ntpd:
>
> for xx.xx.xx.b1 the first line of ntp.conf is the following:
>
> restrict default nomodify notrap
>
> then ntptrace from client.c1 is ok
>
> What causes that solaris clients work in both cases
> and for client.c1 only in case, when noquery is removed from stratum 2 server?
>
> Peter
>
> _______________________________________________
> questions mailing list
> questions at lists.ntp.org
> http://lists.ntp.org/listinfo/questions



More information about the questions mailing list